Bug 1172857 - fpaste --sysinfo missing information on >=f21 (workstation, others?)
Summary: fpaste --sysinfo missing information on >=f21 (workstation, others?)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fpaste
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ankur Sinha (FranciscoD)
QA Contact: Fedora Extras Quality Assurance
URL: https://fedorahosted.org/fpaste/ticke...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-10 22:56 UTC by Branko Grubić
Modified: 2015-06-06 00:06 UTC (History)
4 users (show)

Fixed In Version: fpaste-0.3.7.4-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-28 12:03:49 UTC
Type: Bug


Attachments (Terms of Use)

Description Branko Grubić 2014-12-10 22:56:40 UTC
Description of problem:
I looked at someones 'fpaste --sysinfo' from f21 (xfce spin probably), and I noticed that part which use 'grep' to find 'drm' info from kernel log, returns nothing

"* DRM Information (failed: "grep drm /var/log/dmesg"):
     N/A"

because '/var/log/dmesg' doesn't exist, tested it on my system f21 (workstaion), with '--printonly', same result, but 'dmesg | grep drm' returns a lot of information. 

For this possible (NOT perfect) workaround is probably 'dmesg | grep drm' instead of 'grep drm /var/log/dmesg' (this is probably not perfect if kernel log is too long)
(Also tried  'journalctl -b -k | grep drm' but that looks like misses a lot of things which 'dmesg' shows)


Another related issues is probably on f21 but only workstation (or those which use gdm), '/var/log/Xorg.0.log' doesn't exist it is now in journal only. (I think most other desktop spins have '/var/log/Xorg.*.log' (possible to see it with 'journalctl -b -u gdm' (or maybe something better to filter xorg stuff only, without gdm)

So 
"* Xorg modules (grep LoadModule /var/log/Xorg.0.log | cut -d \" -f 2 | xargs):"
returns nothing, and this 
"* Xorg errors (failed: "grep '^\[.*(EE)' /var/log/Xorg.0.log"):" too

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Branko Grubić 2014-12-10 22:57:19 UTC
This is probably not needed, but, fpaste tested here is fpaste-0.3.7.3.3-1.fc21.noarch

Comment 2 Ankur Sinha (FranciscoD) 2014-12-11 07:38:55 UTC
Thank you for your bugreport, bitlord. I'll look at it ASAP.

Comment 3 Fedora Update System 2015-05-22 15:47:51 UTC
fpaste-0.3.7.4-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/fpaste-0.3.7.4-1.fc22

Comment 4 Fedora Update System 2015-05-22 16:02:33 UTC
fpaste-0.3.7.4-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/fpaste-0.3.7.4-1.fc21

Comment 5 Fedora Update System 2015-05-26 03:17:31 UTC
Package fpaste-0.3.7.4-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fpaste-0.3.7.4-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8747/fpaste-0.3.7.4-1.fc21
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-05-28 12:03:49 UTC
fpaste-0.3.7.4-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2015-06-06 00:06:29 UTC
fpaste-0.3.7.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.