Bug 1172966 - [7.0-3.5] [Hosted-Engine] An error appeared when destroy VM and abort setup during hosted-engine deploy.
Summary: [7.0-3.5] [Hosted-Engine] An error appeared when destroy VM and abort setup d...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Sandro Bonazzola
QA Contact: meital avital
URL:
Whiteboard: node
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-11 08:42 UTC by cshao
Modified: 2016-02-10 20:05 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 08:47:05 UTC
oVirt Team: Node


Attachments (Terms of Use)
/var/log/*.* (6.59 MB, application/x-gzip)
2014-12-11 08:42 UTC, cshao
no flags Details

Description cshao 2014-12-11 08:42:09 UTC
Created attachment 967126 [details]
/var/log/*.*

Description of problem:
An error appeared when destroy VM and abort setup during hosted-engine deploy.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.0-20141202.0.iso
ovirt-node-3.1.0-0.32.20141204gitb8c5332.el7.noarch
ovirt-node-plugin-hosted-engine-0.2.0-6.0.el7ev.x86_64
ovirt-host-deploy-1.3.0-1.el7.noarch
ovirt-hosted-engine-setup-1.2.1-7.el7ev.noarch
ovirt-hosted-engine-ha-1.2.4-2.el7ev.noarch
rhevm-appliance-20141112.0-1.x86_64.rhevm.ova

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor7-7.0-20141202.0.iso with TUI
2. Enable network
3. Config hosted engine with correct stpes.
4. Connect to the VM with vncviewer.
5. Choice "(4) Destroy VM and abort setup" options.

Actual results:
An error appeared when destroy VM and abort setup during hosted-engine deploy.
=========================================================================
          (1) Continue setup - VM installation is complete
          (2) Reboot the VM and restart installation
          (3) Abort setup
          (4) Destroy VM and abort setup
         
          (1, 2, 3, 4)[1]: 4
[ ERROR ] Failed to execute stage 'Closing up': VM destroyed and setup aborted by user
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20141211081842.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination


Expected results:
No error appear when destroy VM and abort setup during hosted-engine deploy.

Additional info:

Comment 1 Sandro Bonazzola 2014-12-11 08:47:05 UTC
Thanks for the report, but this is expected behavior.
A deployment is successful if the hosted engine is fully configured and up and running at the end of the process.
Manually interrupting the setup in the middle of the deployment is considered a deployment error.

Closing this as not a bug.


Note You need to log in before you can comment on or make changes to this bug.