Bug 1173024 - Packages from RPMS should not be updated
Summary: Packages from RPMS should not be updated
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-eclipse46
Version: rh-eclipse46
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: alpha
: 2.3
Assignee: Mat Booth
QA Contact: qe-baseos-tools-bugs
URL:
Whiteboard:
Depends On: 1173035
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-11 10:20 UTC by Matěj Cepl
Modified: 2016-11-15 10:14 UTC (History)
8 users (show)

Fixed In Version: rh-eclipse46-eclipse-4.6.0-3.3.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-15 10:14:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2742 normal SHIPPED_LIVE new packages: rh-eclipse46 2016-11-15 14:52:38 UTC

Description Matěj Cepl 2014-12-11 10:20:46 UTC
Version-Release number of selected component (if applicable):
devtoolset-3-ide-3.0-15.el7.noarch

Steps to Reproduce:
1.run Help/Check for Updates
2.
3.

Actual results:
All Eclipse packages (inclusing those installed from RPMs) are suggested for upgrade

Expected results:
Only packages from the third party repos should be suggested, RPMs are upgraded in the regular RHEL/Fedora manner via yum

Comment 2 Alexander Kurtakov 2014-12-11 10:40:19 UTC
There are 2 parts of the problem.
1. Make sure that at the time of release we ship latest version always - This would give us at least minimal time to look good. This is plain workaround but the best that can be done in the available timeframes. Having a QE check for this would be helpful.
2. Stop shipping plugins as dropins but start using droplets so RPM installed plugins can be locked in the way the main profile is.

Comment 5 Alexander Kurtakov 2015-01-23 17:17:22 UTC
We can't make it for 3.1. Will try for 4.0. Roland, please consider this as push for droplets :).

Comment 6 Alexander Kurtakov 2015-06-29 16:41:55 UTC
Postpone for 4.1 as we failed delivering to 4.0.

Comment 7 Mat Booth 2016-02-11 21:11:01 UTC
At the very least we will not have droplets until DTS 5.0, so I'm bumping this bug.

Comment 9 Václav Kadlčík 2016-08-24 12:31:52 UTC
verified with rh-eclipse46-eclipse-4.6.0-3.5.el7

Comment 11 errata-xmlrpc 2016-11-15 10:14:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2742.html


Note You need to log in before you can comment on or make changes to this bug.