Bug 11731 - rcmd allocate ports above 1024 ? (pb with rshd)
rcmd allocate ports above 1024 ? (pb with rshd)
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-29 09:43 EDT by fabrice.bellet
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-07 15:07:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fabrice.bellet 2000-05-29 09:43:26 EDT
It seems that latest glib-2.1.90 (rcmd ?) allocates local
port above 1024 to clients like rlogin or rsh, which causes
authentication to fail in in.rshd and in.rlogind, because
these servers check that client's source port is in the
range 512-1023.

(do a strace /usr/bin/rsh remote_host cmd and search
the socket that binds on port 514 for example).
Comment 1 Sammy 2000-06-07 15:07:16 EDT
I have been trying all day to figure out why rshd is not working! I have the
same identical problem.

Note You need to log in before you can comment on or make changes to this bug.