This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 117315 - yum-2.0.5.20040229-1 problem = catch-22
yum-2.0.5.20040229-1 problem = catch-22
Status: CLOSED DUPLICATE of bug 117314
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-02 14:58 EST by Hans Christian Studt
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans Christian Studt 2004-03-02 14:58:09 EST
Description of problem:
Today FC2T1 was updated to yum-2.0.5.20040229-1.
The problem is that now yum does not work, which mean I can not
receive a fixed version of yum (catch-22).

Version-Release number of selected component (if applicable
yum-2.0.5.20040229-1

How reproducible:
Always

Steps to Reproduce:
1. yum check-update
  
Actual results:
#yum check-update
Gathering header information file(s) from server(s)
Server: Fedora Core 1.90 - Development Tree
Finding updated packages
Downloading needed headers
Traceback (most recent call last):
  File "/usr/bin/yum", line 30, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum/yummain.py", line 253, in main
    clientStuff.download_headers(HeaderInfo, nulist)
  File "/usr/share/yum/clientStuff.py", line 919, in download_headers
    cachedbdict = returnCacheDBHeaders(nulist)
  File "/usr/share/yum/clientStuff.py", line 901, in returnCacheDBHeaders
    mi = cachedb.dbMatch()
UnboundLocalError: local variable 'cachedb' referenced before assignment

Expected results:
Feching headers
Comment 1 Bart Martens 2004-03-02 15:01:48 EST

*** This bug has been marked as a duplicate of 117314 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:46 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.