Bug 1173243 - codeblocks-contrib is missing astyle.zip
Summary: codeblocks-contrib is missing astyle.zip
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: codeblocks
Version: 21
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1174153 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-11 18:10 UTC by Neil Darlow
Modified: 2014-12-31 23:10 UTC (History)
2 users (show)

Fixed In Version: codeblocks-13.12-13.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-23 18:32:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Neil Darlow 2014-12-11 18:10:00 UTC
Description of problem:

Starting Code::Blocks elicits a dialog with contents -

  The file astyle.zip could not be found.
  Please check your installation.

Sure enough, of the zip files listed for codeblocks-contrib there is no entry for /usr/share/codeblocks/AStyle.zip

Version-Release number of selected component (if applicable):

codeblocks-13.12-8.fc21.src.rpm

How reproducible:

Every time.


Steps to Reproduce:
1. Start Code::Blocks
2. Observe dialog stating astyle.zip could not be found


Actual results:
Error dialog is displayed at startup

Expected results:
Code::Blocks should find the AStyle code formatter zip file

Additional info:

Comment 1 Neil Darlow 2014-12-11 18:28:32 UTC
Doh!

This is a simple one to fix. The problem is in the codeblocks package not codeblocks-contrib.

It is a simple case error. The file is installed as Astyle.zip when Code::Blocks is expecting astyle.zip.

I just renamed this file, as a test, and the problem goes away.

Comment 2 Neil Darlow 2014-12-11 18:33:00 UTC
I also noticed in the Code::Blocks startup log the following:

Scanning for plugins in /usr/lib64/codeblocks/plugins
Plugin resource not found: libAstyle.zip

Those files are .so not .zip so there's something odd going on here.

In suggest the whole packaging process is checked for other similar errors.

Comment 3 Fedora Update System 2014-12-12 09:25:02 UTC
codeblocks-13.12-13.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/codeblocks-13.12-13.el7

Comment 4 Fedora Update System 2014-12-12 09:26:13 UTC
codeblocks-13.12-13.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/codeblocks-13.12-13.fc21

Comment 5 Fedora Update System 2014-12-12 23:08:05 UTC
Package codeblocks-13.12-13.el7:
* should fix your issue,
* was pushed to the Fedora EPEL 7 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing codeblocks-13.12-13.el7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-4646/codeblocks-13.12-13.el7
then log in and leave karma (feedback).

Comment 6 Dan Horák 2014-12-15 12:19:27 UTC
*** Bug 1174153 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2014-12-23 18:32:10 UTC
codeblocks-13.12-13.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-12-31 23:10:00 UTC
codeblocks-13.12-13.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.