Bug 11733 - xfs could not create dir /etc/X11/fs/.xauth
Summary: xfs could not create dir /etc/X11/fs/.xauth
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 6.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-29 16:06 UTC by Bill Winspur
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-30 17:58:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Winspur 2000-05-29 16:06:58 UTC
I'm trying to get true type fonts installed on my linux box as per the
HOWTO, and am have gotten myself into difficulties.
SITUATION
---------
xfs now fails to start on my system, posting the following into the
message log:
May 15 10:27:01 wynngate PAM_pwdb[456]: (su) session opened for user xfs
by (uid=0)
May 15 10:27:01 wynngate pam_xauth[456]: do_file: could not create
dir /etc/X11/fs/.xauth
May 15 10:27:01 wynngate PAM_pwdb[456]: (su) session closed for user xfs
May 15 10:27:01 wynngate pam_xauth[456]: do_file: could not create
dir /etc/X11/fs/.xauth
May 15 10:27:01 wynngate xfs: xfs startup succeeded (NOT TRUE - no xfs
process !)

HOW I GOT TO THIS POINT
-----------------------

Prior to this state of affairs I had done the following:

1. Created the directory truetype in /usr/X11R6/lib/X11/fonts
2. Copied the truetype fonts from my windows NT system to the truetype
directory
3. Performed chkfontpath --add /usr/X11R6/lib/X11/fonts/truetype
4. Performed ttmkfdir -o fonts.scale - which created fonts scale
5. FAILED TO PERFORM mkfontdir !!!! --- (in retrospect, words fail me)
6. booted my system to re-start XFS and X
7. Performed ps ax|grep xfs, which failed to find xfs.
8. Found the above xfs status and messages from the boot process.

RECOVERY ATTEMPTS (Trying to get back to square 1)
-----------------
9. a) Deleted directory truetype
   b)Performed chkfontpath --remove /usr/X11R6/lib/X11/fonts/truetype
10. Rebooted - still have the above problem.


CURRENT /etc/X11/fs/config CONTENT
----------------------------------
#
# Default font server configuration file for Red Hat Linux 6.0
#

# allow a max of 4 clients to connect to this font server
client-limit = 4

# when a font server reaches its limit, start up a new one
clone-self = off

# alternate font servers for clients to use
#alternate-servers = foo:7101,bar:7102

# where to look for fonts
# Some of these are commented out, i.e. the TrueType and Type1
# directories in /usr/share, because they aren't forced to be
# installed alongside X.
#
catalogue = /usr/X11R6/lib/X11/fonts/misc:unscaled,
 /usr/X11R6/lib/X11/fonts/75dpi:unscaled,
 /usr/X11R6/lib/X11/fonts/100dpi:unscaled,
 /usr/X11R6/lib/X11/fonts/misc,
 /usr/X11R6/lib/X11/fonts/Type1,
 /usr/X11R6/lib/X11/fonts/Speedo

# in 12 points, decipoints
default-point-size = 120

# 100 x 100 and 75 x 75
default-resolutions = 75,75,100,100

# how to log errors
use-syslog = on

CONCLUSION
----------
I see from bugzilla that xfs has failed to start for many reasons, so if
there is a workaround for getting truetype fonts to go without XFS I'd be
happy to use it. Is 6.2 a better bet wrt XFS ?

Comment 1 Preston Brown 2000-05-30 17:58:59 UTC
There are many fixes for xfs in RHL 6.1 and 6.2.  You should upgrade.


Note You need to log in before you can comment on or make changes to this bug.