Bug 117333 - Perl has SIGCHLD set to SIG_IGN but calls wait()
Summary: Perl has SIGCHLD set to SIG_IGN but calls wait()
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: perl (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-02 21:40 UTC by Milan Kerslager
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-08 19:16:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Milan Kerslager 2004-03-02 21:40:03 UTC
When initializing OpenWebMail Perl application I've got this error
message from kernel (2.4.21-9.0.1.EL):

application bug: perl5.8.0(16102) has SIGCHLD set to SIG_IGN but calls
wait(). (see the NOTES section of 'man 2 wait'). Workaround activated.

This seems to be a Perl bug. The initial creation of *.db files take
looong time, probably because this bug. The command was (just after
installation of OpenWebMail RPM package):

/usr/share/openwebmail/cgi-bin/openwebmail-tool.pl --init

I have OpenWebMail and related modules in my yum repository, you may
try them from here:

ftp://ftp.vslib.cz/pub/local/milan.kerslager/RHEL-3/RPMS/
http://ftp.linux.cz/pub/linux/people/milan_kerslager/RHEL-3/RPMS/

OpenWebMail has homepage here: http://openwebmail.org

Comment 1 Chip Turner 2004-03-08 19:16:09 UTC
this is an issue with the program itself and not perl.  check the
sources of OpenWebMail to find if they are setting the signal that
way.  it is reporting as a perl issue since the perl script uses the
perl executable, but it is the program causing issues and not perl itself.

this is detailed in the 'man 2 wait' manpage.  Search for SIG_IGN.


Note You need to log in before you can comment on or make changes to this bug.