Bug 1173335 - There is not "no_proxy" filter option when using proxy.
Summary: There is not "no_proxy" filter option when using proxy.
Keywords:
Status: CLOSED DUPLICATE of bug 1132980
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Management
Version: 6.0.6
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-11 21:29 UTC by Harald Jensås
Modified: 2021-06-10 10:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-23 13:54:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Harald Jensås 2014-12-11 21:29:24 UTC
Description of problem:
Satellite 6 is on a network, behind a proxy. To be able to sync content from Red Hat or other external repos the Satellite will have too go trough the proxy.

There are also internal repos on the network, the proxy server cannot access these, but the Satellite itself can access them. 

Version-Release number of selected component (if applicable):


How reproducible:
Reproducable

Steps to Reproduce:
1. Install Sat on network behing proxy, enable the --katello-proxy-* options.
2. Set up yum repo on another system on the repo, served via http.
3. Create a product, and a repo.
4. Add the http://<....> URL for the yum repo on the server on the internal network.
5. If the proxy cannot access the internal repo, sync will fail.

Actual results:
Sync fail because proxy cannot access the host serving the internal repo.

Expected results:
A "no_proxy" option should be available to allow configuration of domans, subnets, hosts etc that Satellite should not use the proxy to access.

Additional info:

Comment 1 RHEL Program Management 2014-12-11 21:35:02 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Stephen Benjamin 2015-04-23 13:54:01 UTC

*** This bug has been marked as a duplicate of bug 1132980 ***


Note You need to log in before you can comment on or make changes to this bug.