Bug 117339 - Chunk of UI missing, unable to create zones
Chunk of UI missing, unable to create zones
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-bind (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John Ha
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-02 17:24 EST by Ansel Halliburton
Modified: 2014-08-04 18:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 01:08:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the bug (62.11 KB, image/png)
2004-03-02 17:26 EST, Ansel Halliburton
no flags Details
Screenshot #1 (74.30 KB, image/png)
2004-03-25 15:46 EST, Ansel Halliburton
no flags Details
Screenshot #2 (74.88 KB, image/png)
2004-03-25 15:47 EST, Ansel Halliburton
no flags Details
Screenshot #3 (76.17 KB, image/png)
2004-03-25 15:48 EST, Ansel Halliburton
no flags Details

  None (edit)
Description Ansel Halliburton 2004-03-02 17:24:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
Please refer to Figure 28-2 at:
http://www.redhat.com/docs/manuals/enterprise/RHEL-3-Manual/sysadmin-guide/ch-bindconf.html#S1-BINDCONF-FORWARD-MASTER-ZONE

When using redhat-config-bind, I do not see the "Records" panel shown
in Figure 28-2.  This is a critical part of the program, and its not
being there makes redhat-config-bind useless.

As far as I am concerned, this bug makes redhat-config-bind completely
useless.  Also, I was disappointed to see WORSE functionality in RHEL3
than RH9.

Version-Release number of selected component (if applicable):
redhat-config-bind-2.0.0-14

How reproducible:
Always

Steps to Reproduce:
1. Run redhat-config-bind
2. Click "New"
3. select "Forward Master Zone", and enter a domain name (e.g. bug.com)
3. Click OK


Actual Results:  I have posted the exact screen I get at
http://www.anseljh.com/rhbug/1.png

There is no "Records" panel, so I am unable to add hosts to a domain.

This differs greatly from what is described and shown in the
documentation.

Expected Results:  Referring to
http://www.redhat.com/docs/manuals/enterprise/RHEL-3-Manual/sysadmin-guide/ch-bindconf.html#S1-BINDCONF-FORWARD-MASTER-ZONE,
I expected to see the UI shown in Figure 28-2, complete with a
"Records" panel.  (This would also be what I have seen previously in
RH8 & 9)

Additional info:

0) /etc/redhat-release says: Red Hat Enterprise Linux ES release 3
(Taroon Update 1)

1) I also tried resizing the window, hoping that perhaps the "Records"
panel is hiding somewhere.  It's not.

2) This system was installed from RHEL3 Update 1 ISOs that I
downloaded from Red Hat Network, and the system is fully patched.

3) I have another RHEL3 system, installed from the same ISOs, that
exhibits this same problem.

4) This bug prevented me from adding any working records to BIND.  I
had to manually create the zone files using Emacs instead, which is
why you see the other domains in my screenshot.  They were NOT created
with redhat-config-bind.
Comment 1 Ansel Halliburton 2004-03-02 17:26:19 EST
Created attachment 98216 [details]
Screenshot of the bug

This is a screenshot of the bug
Comment 3 Daniel Walsh 2004-03-25 13:25:47 EST
Please try system-config-bind from rawhide.  It has lots of fixes.
Comment 4 Ansel Halliburton 2004-03-25 14:50:08 EST
I tried system-config-bind-2.0.2-3.1.noarch.rpm from:
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/

The UI looked exactly the same as the redhat-config-bind that shipped
with RHEL 3.  Still couldn't get it to behave as described in
documentation etc.  The "Records" panel was still not there.

If that's not what you meant for me to try, give me more specifics and
I'm more than happy to try again.
Comment 5 Daniel Walsh 2004-03-25 14:58:30 EST
Sorry, I did not read you bugzilla properly.  I have been going
through a hundred of them today.  The add record functionality is now
on the front screen.   Select the domain you wish to add a record to
and click the add record button.

Dan
Comment 6 Ansel Halliburton 2004-03-25 15:46:10 EST
Thanks for the quick response.  

After messing around a bunch more, I did manage to get it to work. 
However, the documentation that shipped with RHEL 3 is totally wrong
and doesn't cover this version of redhat-config-bind.  I am probably
far from the only person that's been confused by this.  (I would bump
it over to the docs people as fairly urgent.)

I will be super-specific as to what I did and saw:

* run system-config-bind.  Opened up the Help->About to verify version.

* Click "New" button to make a new zone, call it "foobar.com"
(Screenshot #1)  Click OK.

* Type in a primary nameserver for the zone. (Screenshot #2)  Click OK.

* Click "Add Record" button.  Type in "www" for host name,
"12.34.56.78" for IP address.  Click Ok.

* Click "Add Record" button.  Type in "mail" for host name,
"12.34.56.78" for IP address.  Click Ok. (Screenshot #3)


So far so good.  Now I want to add an MX for foobar.com.


* Click "Add Record" button. Click "Mail Exchange" tab. (Screenshot #4)

At this point I got pretty confused because this is very different
from the docs.  After trying a bunch of stuff, I finally put in
"foobar.com." for name and picked mail.foobar.com. for the mail server.

With this part done, I tried to save - however I got error messages
complaining that 1) my new zone didn't have a nameserver and 2) my
localhost record needed to have a nameserver too.  I added a
nameserver for the new zone and completely deleted the localhost
record.  With that done, I finally managed to save successfully.
Comment 7 Ansel Halliburton 2004-03-25 15:46:58 EST
Created attachment 98858 [details]
Screenshot #1

Screenshot #1 as described above
Comment 8 Ansel Halliburton 2004-03-25 15:47:32 EST
Created attachment 98859 [details]
Screenshot #2

Screenshot #2 as described above
Comment 9 Ansel Halliburton 2004-03-25 15:48:05 EST
Created attachment 98860 [details]
Screenshot #3

Screenshot #3 as described above
Comment 12 Jay Turner 2004-09-02 01:08:19 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-364.html

Note You need to log in before you can comment on or make changes to this bug.