This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 117344 - Kudzu leaves xterms in bad state
Kudzu leaves xterms in bad state
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: slang (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-02 18:15 EST by Bjorn Helgaas
Modified: 2013-03-08 11:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-08 11:04:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script of timeconfig (7.72 KB, application/octet-stream)
2007-09-18 16:09 EDT, Bjorn Helgaas
no flags Details

  None (edit)
Description Bjorn Helgaas 2004-03-02 18:15:16 EST
Kudzu leaves xterms in a bad state 
 
Version-Release number of selected component (if applicable): 
  Kudzu in RHEL 3 U1 
 
How reproducible: 
If the hardware configuration changes and Linux Kudzu runs during 
boot and the console is being viewed, Kudzu leaves the xterm in a 
fixed 24x80 screen size regardless of the original xterm screen 
size.  
 
Steps to Reproduce: 
Start an xterm via Reflection X on a PC or on an HP-UX workstation. 
View a Linux console when it boots and runs Kudzu. After Kudzu 
completes, the xterm is stuck at 24x80 and is no longer usable.  
 
Contact Greg Albrecht <gregory_albrecht@am.exch.hp.com> for 
more information.
Comment 1 Bill Nottingham 2004-03-02 22:49:24 EST
Does this happen with other text-based config tools?
Comment 2 Bjorn Helgaas 2004-03-03 11:38:30 EST
From Greg:  
  
> I have not used any other text-based config tools, so  
> I don't know. Suggest some to try and I can do so.  
  
> This used to occur during the initial Linux install. I  
> can't remember whether it still occurs on an install or  
> not. I can retry an install and pass that information  
> along. For me, the Kudzu issue occurs more frequently  
> due to hardware reconfigurations and Linux reboots.  
 
Is there a way to add Greg (gregory_albrecht@am.exch.hp.com) 
to the CC: list?  I tried the "Add CC:" box, but it 
didn't work (maybe because Greg doesn't have a Bugzilla 
account?) 
 
Comment 3 Suzanne Hillman 2004-03-03 14:18:44 EST
Greg does need to create a Bugzilla account, and to have that account
added to the CC list after it is created.
Comment 4 Bjorn Helgaas 2005-09-20 17:58:14 EDT
Greg said: 
 
> Suggest some to try and I can do so. 
 
What other text-based config tool should we try? 
Comment 5 Bill Nottingham 2005-09-20 18:01:50 EDT
authconfig, system-config-network-tui, mouseconfig, timeconfig, etc.
Comment 6 Thomas E. Dickey 2005-09-20 18:27:53 EDT
Is the xterm not resizable after calling kudzu?

If it's resizable (but simply resized to 24x80),
this reminds me of a Debian report last year which
was explained by an application calling tset
(which sets the window size).
Comment 8 Bill Nottingham 2007-09-18 15:16:45 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.

Users who have experienced this problem are encouraged to upgrade to the latest
update release, and if this issue is still reproduceable, please contact the Red
Hat Global Support Services page on our website for technical support options:
https://www.redhat.com/support

Comment 9 Bjorn Helgaas 2007-09-18 16:09:16 EDT
Created attachment 198821 [details]
script of timeconfig

Sorry, I poked Greg for more information in September 2005, but never
followed up on it.

I just tried "timeconfig" myself on RHEL5, and the problem does occur
on a console (ttyS0) connection, but not on an ssh connection.

This typescript shows timeconfig running on the console.  This starts in
a 72x80 xterm, and after timeconfig exits, only 24x80 of the xterm is
scrollable.
Comment 10 Thomas E. Dickey 2007-09-18 16:25:25 EDT
That's expected (from reading the attachment):
the program sets the scrolling margins and doesn't reset them.
Comment 11 Bill Nottingham 2007-09-18 17:01:54 EDT
So, that would imply a newt bug.
Comment 12 Bill Nottingham 2007-09-18 17:03:14 EDT
Reassigning to newt. The chances of this being fixed for RHEL 3 at this point
are pretty nil, though. Feel free to move to RHEL 5 if it still happens there.
Comment 13 Bjorn Helgaas 2007-09-18 18:35:40 EDT
I don't care about RHEL 3 anymore.  My attachment in comment #9 is from
RHEL 5, so the problem still exists there.  I tried to change the version
to 5 and hardware to "all" above.
Comment 14 Miroslav Lichvar 2007-09-19 12:10:10 EDT
Newt uses slang. Unfortunately, I'm not sure there is anything we can do in
slang to prevent this.

When terminal doesn't have correct window size, slang and ncurses applications
will use wrong values and this will cause the problem.

Which program is used for serial communication?
Comment 15 Bjorn Helgaas 2007-09-19 12:50:33 EDT
Typical scenario is one of these:

  sh -- xterm -- bash -- telnet
  sh -- xterm -- bash -- ssh

The telnet or ssh connection is to an HP management processor (MP).  One thing 
the MP can do is connect you to a ttyS serial device that is the console.

I think newt/slang is using the xterm escape sequence "ESC[1;24r" to set the 
scrolling region to lines 1-24.  On exit, could it use "ESC[;r" to set the 
scrolling region to the full size of the window?  Or maybe it could 
use "ESC[18;;t", which looks like it should report the size of the text area?

Newt/slang is using an xterm escape sequence to set the scrolling margins.  Is 
there a similar sequence it could use to read the current margins, so it could 
restore them on exit?
Comment 16 Thomas E. Dickey 2007-09-19 13:01:16 EDT
On exit, it should use "ESC[r" to reset the scrolling
margins.  Normal practice is to reset them after the
scrolling operation is no longer needed.
Comment 17 Miroslav Lichvar 2007-09-19 13:19:36 EDT
Ok, I was assuming that if ncurses don't use it, there is a reason why it
shouldn't be used.
Comment 18 Thomas E. Dickey 2007-09-19 14:45:07 EDT
ncurses does use the scrolling regions, but the sequence of operations
appears to be different...
Comment 19 RHEL Product and Program Management 2007-12-03 15:38:51 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 20 Miroslav Lichvar 2013-03-08 11:04:44 EST
We are sorry, but at this point in the RHEL5 release cycle, where only critical and security bugs are fixed, this bug is unlikely to be addressed.

Note You need to log in before you can comment on or make changes to this bug.