Bug 117350 - Buglet in /etc/bashrc
Buglet in /etc/bashrc
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: setup (Show other bugs)
3.0
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 75663 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-02 21:10 EST by John Morris
Modified: 2014-03-16 22:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.5.32-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-02 22:48:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Morris 2004-03-02 21:10:10 EST
Description of problem:

Buglet in /etc/bashrc.  Need an "unset i" at the end to prevent
garbage ending up in the default environment.

Version-Release number of selected component (if applicable):

At least in setup-2.5.27-1

How reproducible:

Always.

Steps to Reproduce:
1. Open a shell
2. type set
3. observe the last item, on my machine it is
i=/etc/profile.d/which-2.sh
Comment 1 Bill Nottingham 2004-03-02 22:48:22 EST
Will be fixed in 2.5.32-1, thanks!
Comment 2 Bill Nottingham 2004-05-04 00:56:10 EDT
*** Bug 75663 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.