Bug 1173540 - No timeout and error status when optimizer machine is blocked by iptables from engine machine
Summary: No timeout and error status when optimizer machine is blocked by iptables fro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-optimizer
Version: 3.5.0
Hardware: All
OS: All
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Martin Sivák
QA Contact: Shira Maximov
URL:
Whiteboard:
Depends On:
Blocks: 1232536
TreeView+ depends on / blocked
 
Reported: 2014-12-12 11:51 UTC by Lukas Svaty
Modified: 2016-03-09 20:21 UTC (History)
5 users (show)

Fixed In Version: ovirt-optimizer-0.9
Doc Type: Bug Fix
Doc Text:
Previously, the default configuration for jQuery requests did not time out. If incoming and outgoing connections to the Optimizer machine were blocked from the Manager, there were no indications that the connections were blocked. With this update, the UI plug-in reports an error if the Optimizer machine can not be reached within 60 seconds.
Clone Of:
Environment:
Last Closed: 2016-03-09 20:21:38 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0427 normal SHIPPED_LIVE ovirt-optimizer bug fix and enhancement update 2016-03-10 01:19:39 UTC
oVirt gerrit 41293 master MERGED Add connection timeouts to the UI plugin Never

Description Lukas Svaty 2014-12-12 11:51:26 UTC
Description of problem:
When optimizer machine is blocked by iptables on engine machine, optimizer-ui plugin shows last solution it recieved from optimizer even that it is not up to date. After some timeout some error message should be displayed in status.

Version-Release number of selected component (if applicable):
ovirt-optimizer-ui-0.4-5.noarch

How reproducible:
100%

Steps to Reproduce:
1. Have working ovirt-optimizer
2. Wait for solution to be recieved
3. Block incoming and outcoming connection to optimizer from engine machine

iptables -I INPUT 1 -s $optimizerIp -j DROP
iptables -I OUTPUT 1 -s $optimizerIp -j DROP

Actual results:
Solution recieved

Expected results:
Any other status as solution was not recieved :)

Comment 1 Eyal Edri 2015-02-25 08:40:17 UTC
3.5.1 is already full with bugs (over 80), and since none of these bugs were added as urgent for 3.5.1 release in the tracker bug, moving to 3.5.2

Comment 4 Shira Maximov 2015-10-11 16:04:39 UTC
verified on : Red Hat Enterprise Virtualization Manager Version: 3.6.0-0.18.el6

Comment 5 Julie 2016-02-22 04:53:17 UTC
Hi Martin, 
   I have updated the doc text. The original doc text said time out is 30 seconds but the gerrit commit said 60 seconds so I've changed the doc text to 60 seconds. Please have a look and let me know if it is correct.

Cheers,
Julie

Comment 6 Martin Sivák 2016-02-29 09:46:44 UTC
Ack. But shouldn't the sentence about blocked connections use plural? "were blocked?"

Comment 7 Julie 2016-02-29 12:02:07 UTC
Thanks for reviewing the doc text. Fixed.

Cheers,
Julie

Comment 9 errata-xmlrpc 2016-03-09 20:21:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0427.html


Note You need to log in before you can comment on or make changes to this bug.