Bug 1173551 - Optimizer should not propose steps if solution is not doable
Summary: Optimizer should not propose steps if solution is not doable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-optimizer
Version: 3.5.0
Hardware: All
OS: All
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Martin Sivák
QA Contact: Shira Maximov
URL:
Whiteboard:
Depends On:
Blocks: 1232536
TreeView+ depends on / blocked
 
Reported: 2014-12-12 12:08 UTC by Lukas Svaty
Modified: 2016-03-09 20:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously, when users executed a solution step suggested by the Optimizer, if the solution wasn't doable, an error message was returned. This was confusing for users. With this update, if the full solution is not doable, the solution is still displayed but grayed out so it is clear to users that the full solution is not possible to implement at the time. Users can still read the suggested solution and manually implement parts of the solution that are doable.
Clone Of:
Environment:
Last Closed: 2016-03-09 20:21:45 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)
optimizer-ui plugin (39.92 KB, image/png)
2014-12-12 12:08 UTC, Lukas Svaty
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0427 normal SHIPPED_LIVE ovirt-optimizer bug fix and enhancement update 2016-03-10 01:19:39 UTC
oVirt gerrit 40602 master MERGED Gray out the solution when hard constraints are violated Never

Description Lukas Svaty 2014-12-12 12:08:05 UTC
Created attachment 967615 [details]
optimizer-ui plugin

Description of problem:
When solution is not doable optimizer should not propose any steps how to achieve this un-doable solution :)

Version-Release number of selected component (if applicable):
ovirt-optimizer-0.4-5.noarch

How reproducible:
100%

Steps to Reproduce:
1. 2x8GB host1, host2, 3x 2GB VM1 (host1), VM2 (host1), VM3 (host2).
2. set optimizer in config to compute just 1 step
3. Optimize start VM-big with 7 GB of memory


Actual results:
Solution is not doable. Optimizer suggesting migration of VM/start of VM-big.
See screenshot attached.

Expected results:
If solution is not doable dont suggest any steps to perform. 
Two ways to handle this:
1. let admin handle this on his own
2. suggest the best solution how to make solution doable

Additional info:
Might be connected to these ones:
https://bugzilla.redhat.com/show_bug.cgi?id=1171491
as on screenshot optimizer is suggesting running VM-big on host where engine should not allow this

But I think after fixing this issue optimizer will still suggest migration of the VM. That would not work in case we have 4x2GB VM on hosts and trying to optimize start VM-big with 8GB. There is just not enough space on the hosts for these 5 VMs so solution is not doable, but optimizer will try to find some steps for it either way.

Comment 1 Martin Sivák 2014-12-15 09:48:57 UTC
*** Bug 1173117 has been marked as a duplicate of this bug. ***

Comment 2 Lukas Svaty 2015-01-05 10:14:41 UTC
Actually optimizer is missing some rules for VMs that are pinned to host (Migration option: Do not allow migration). Because of this this is not a duplicate of mentioned issues. It's a bug in optimizer.

Steps:
1. 1 host in cluster
2. 1 VM to cluster
3. Edit VM -> Host -> Migration options: 'Do not allow migration'
4. Run VM
5. Solution is not duable. 

The fix should be included in 3.5.1.

Comment 3 Martin Sivák 2015-01-05 12:38:21 UTC
The original description says that Optimizer should not report steps that are not doable. The Comment 2 describes a optimization rules bug. Those two are not related. Open a new bug.

Comment 4 Martin Sivák 2015-05-06 12:56:44 UTC
The updated version will clearly state that the user should wait for a better solution and it will display the solution in semi-transparent / grayed out fashion just to illustrate what it is doing.

Comment 7 Shira Maximov 2015-11-19 15:23:55 UTC
verified on :
Red Hat Enterprise Virtualization Manager Version: 3.6.0.3-0.1.el6 

verification steps:
1. 1 host in cluster
2. 1 VM to cluster
3. Edit VM -> Host -> Migration options: 'Do not allow migration'
4. Run VM
5. Solution is not duable.

Comment 8 Julie 2016-02-22 04:29:35 UTC
If this bug requires doc text for errata release, please provide draft text in the doc text field in the following format:

Cause:
Consequence:
Fix:
Result:

The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to -.

Comment 12 errata-xmlrpc 2016-03-09 20:21:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0427.html


Note You need to log in before you can comment on or make changes to this bug.