Bug 117364 - rpm-build always crashes with a segmentation fault when trying to compile src rpm packages
Summary: rpm-build always crashes with a segmentation fault when trying to compile src...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-03 11:30 UTC by Bernd Waibel
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 16:46:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernd Waibel 2004-03-03 11:30:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040225 Firefox/0.8

Description of problem:
When using rpmbuild -bp on spec file or rpmbuild --rebuild on a src
rpm file, then rpmbuild always crashes with a segmentation fault.

This problem always occurs. At first I thought that maybe the package
I used has some errors, but then trying other packages, always the
same problem arises.

I have a nearly clean Fedora Core install with only a few packages
from Fedora.us and a few other packages (mainly audio and video
related applications and libraries) from FreshRPMs installed. Beyond
this I have also installed the mono packages from Ximian.

I am not sure, if this problem also occurs immediately after the
installation of Fedora Core. But I don't know with which appl/libs
rpmbuild could have problems.

The package I would to build is the alsa-driver package. I build a new
kernel yesterday, because I need NTFS filesystem support by the kernel
to access (read-only) some of my data which is located on a NTFS
partition I had to use over the last few years. But then I also need
to compile a new alsa-driver package, or include the package in the
kernel.

There may be other ways in this case to accomplish this task, but the
problem does still exist with other packages.

Version-Release number of selected component (if applicable):
rpm-build-4.2.1-0.30

How reproducible:
Always

Steps to Reproduce:
1. call rpmbuild --rebuild alsa-driver-1.0.2c-1.fr.src.rpm
2.
3.
    

Actual Results:  Program output: Segmentation fault
after that the prompt appears.

Expected Results:  My package should have been compiled and a binary
package should have been built.

Additional info:

see description of the bug.

Comment 1 Jeff Johnson 2004-03-03 19:38:05 UTC
Can you supply a URL to exactly the alsa src.rpm that
you are trying to build so that I can try to reproduce?



Comment 3 Bernd Waibel 2004-03-05 21:47:39 UTC
yep that's the right one

Comment 4 Jeff Johnson 2004-12-07 16:46:59 UTC
I suspect that this problem is (or rather was) due to
other causes than rpm flaws. Feel free to reopen if
my guess is wrong.


Note You need to log in before you can comment on or make changes to this bug.