Bug 117366 - olympus-p400, Media Tray Empty!, usb
olympus-p400, Media Tray Empty!, usb
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-03 07:11 EST by HenrikLarsson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-03 08:08:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description HenrikLarsson 2004-03-03 07:11:43 EST
Description of problem:

I installed a Fedora 1 release which unfortunatly has cups 19-13 on 
meaning there was no lpadmin, lpstat etc utilities.  I then installed 
various binary packages of gimp, gimp-print, gimp-print-cups and cups 
finally settling with the latest and greatest (as far as I could 
determine, see below).  I cannot get my printer to print despite 
lpstat -t showing (increasing) data tranfer


Version-Release number of selected component (if applicable):

currently, but also with various combo's

cups-1.1.20-2
gimp-1.2.5-1
gimp-print-4.2.6-4
gimp-print-cups-4.2.6-2

How reproducible:


Steps to Reproduce:
1.  Install Fedora 1 with any version of cups allowing lpstat.
2.  Attach and switch on an Olympus-P400 dye sub printer
3.  open gimp and select print (use olympus printer)
  
Actual results:

lpstat -t shows all looks well; while;true;do;lpstat -t;sleep 1;done
The error log has a Warning (?) message about Media Tray Empty!
if you > the /var/log/cups/error_log before attempting to print then 
afterwards you will see a dump of a buffer of Zeros using vi for 
example (I checked this using emacs in hexl-mode) coming from 
somewhere.


Expected results:

You already know this I think ;-)

Additional info:

I can read the /dev/usb/lp0 device and read back the printer string.
Comment 1 Tim Waugh 2004-03-03 07:20:18 EST
'cups 19-13' isn't a version number, but presumably you mean
cups-1.1.19-13 -- but this package does indeed contain the lpstat etc
utilities.  There is a known bug (logged in bugzilla) with upgrades
not switching over properly from LPRng, which it sounds like you might
have run into.  Use 'redhat-switch-printer' to set the print spooler
to CUPS.

You don't say whether this media message prevents you from printing --
it shouldn't, and I believe it to be something that can be ignored.

Could you confirm that this is the case, and that this bug report is
that the message is bogus?
Comment 2 HenrikLarsson 2004-03-03 07:34:59 EST
Indeed you are correct about the cups version.  I saw the upgrade bug 
and checked rpm -q LPRng that LPRng was not on there.  I agree that I 
could have run into this however lpstat and all the other utilities 
now work.  I have also recompiled all the packages I mention instead 
of using binaries and the ppd filter I have has come from the latest 
gimp-print targz file.  When installing cups informed me in the error 
log about where it was looking for it and I put it there

This sentence in the original report

I cannot get my printer to print despite lpstat -t showing 
(increasing) data tranfer

was the clue to the problem.  I cannot confirm that this message is 
related however its the only clue I have.  The printer will print 
from a media card so the message is for sure wrong.
Comment 3 Tim Waugh 2004-03-03 07:45:01 EST
See:
http://www.linuxprinting.org/show_printer.cgi?recnum=Olympus-P-400

The stable branch of the gimp-print driver does not seem to support
this model yet, but development for its support is under way.
Comment 4 HenrikLarsson 2004-03-03 07:58:41 EST
"the ppd filter I have has come from the latest gimp-print targz 
file."

i.e > 4.3.20

"The printer should work with the version 4.3.20 or newer of the 
development line."

I basically extracted the olypus-p400.ppd file from the ./configure 
part of the gimp print install.

This is the driver, and its a standard PPD file olympus-p400 it 
should therefore be processed in the same way IMHO as any other PPD 
file.  the usb backend doesnt care about it so IMHO it should work.

If I'm wrong Is there an rpm (src or bin) I could use ?.

Comment 5 Tim Waugh 2004-03-03 08:08:43 EST
Not enough to have the PPD -- you need the actual driver code as well!
Comment 6 HenrikLarsson 2004-03-03 08:15:58 EST
Thanks Tim, From what I read I thought all I needed was the ppd esp 
since it got to the printer spooler.  I guess I'm going to have to 
hack the system.

Pete.

Note You need to log in before you can comment on or make changes to this bug.