Bug 11737 - Expect perl module DOES NOT WORK due to missing pty.pm
Summary: Expect perl module DOES NOT WORK due to missing pty.pm
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: perl-Mon   
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Tim Powers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-29 20:53 UTC by jonathan_95060
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-17 18:47:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error output from perl (378 bytes, text/plain)
2000-05-29 20:55 UTC, jonathan_95060
no flags Details
sample perl script that tries to "use Expect;" (456 bytes, text/plain)
2000-05-29 21:00 UTC, jonathan_95060
no flags Details

Description jonathan_95060 2000-05-29 20:53:26 UTC
This is really a bug report for perl-Expect.pm-1.07-2.i386.rpm.  The WWW
page would not let me specify this component so I'm filing this against
perl-Mon to get your attention.

the Expect.pm "uses" IO::Pty but the Pty.pm is not included in the
powertools RPM.

I believe the module that is required is

	IO-Tty-0.02

I fetched the IO-Tty-0.02.tar.gz, built and installed it and then
the expect module worked fine.

Cheers,
  --jfc

Comment 1 jonathan_95060 2000-05-29 20:55:59 UTC
Created attachment 276 [details]
error output from perl

Comment 2 jonathan_95060 2000-05-29 21:00:59 UTC
Created attachment 277 [details]
sample perl script that tries to "use Expect;"

Comment 3 Tim Powers 2000-07-17 18:47:42 UTC
It shouldn't be included in the same package as the perl-expect package since it
is a different module in CPAN. Keep in mind that the packages for CPAN are
auto-generated, so it won't suck in dependancies automagically. What you will
want to do is grab the perl-IO-Tty package from the CPAN packages which were
included in 6.2, look in the "extra-SRPMS" directory. The sources are in that
package. Just a FYI: the extra-SRPMS directory is for packages which are useful
to people but wouldn't build for us for whatever reason (messed up makefile,
missing libs on the system, whatever).


Note You need to log in before you can comment on or make changes to this bug.