Bug 1173702 - Can't pip install MySQL-python
Summary: Can't pip install MySQL-python
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mariadb
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Honza Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-12 17:45 UTC by Derek Higgins
Modified: 2015-01-07 01:24 UTC (History)
5 users (show)

Fixed In Version: mariadb-10.0.15-3.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-20 08:36:33 UTC


Attachments (Terms of Use)
Output Error (8.66 KB, text/plain)
2014-12-12 17:47 UTC, Derek Higgins
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 1401957 None None None Never

Description Derek Higgins 2014-12-12 17:45:51 UTC
Description of problem:
pip can't install MySQL-python since the update to mariadb-devel.i686 1:5.5.40-1.fc20


Version-Release number of selected component (if applicable):
mariadb-devel.i686 1:5.5.40-1.fc20

How reproducible:
Every time 

Steps to Reproduce:
virtualenv --no-site-packages openstack
source openstack/bin/activate
pip install MySQL-python

Actual results:
/usr/include/mysql/my_config_i386.h:654:2: error: #error <my_config.h> MUST be included first!
#error <my_config.h> MUST be included first!
^
error: command 'gcc' failed with exit status 1


I will attach full error output

Expected results:
successful install

Additional info:
Note I am using a non distro installed pip and virtaulenv
pip 1.5.6 from /root/openstack/lib/python2.7/site-packages (python 2.7)
virtualenv (1.11.6)

Comment 1 Derek Higgins 2014-12-12 17:47:03 UTC
Created attachment 967773 [details]
Output Error

Comment 3 Fedora Update System 2014-12-16 08:49:24 UTC
mariadb-5.5.40-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mariadb-5.5.40-2.fc20

Comment 4 Fedora Update System 2014-12-16 08:50:06 UTC
mariadb-5.5.40-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mariadb-5.5.40-2.fc19

Comment 5 Matthew Miller 2014-12-16 20:28:49 UTC
We got a note that this affects F21 too. Since that's 10.0 instead of 5.5, do you want a new bug for that?

Comment 6 Fedora Update System 2014-12-18 06:03:42 UTC
Package mariadb-5.5.40-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mariadb-5.5.40-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-17110/mariadb-5.5.40-2.fc19
then log in and leave karma (feedback).

Comment 7 Honza Horak 2014-12-18 15:51:08 UTC
(In reply to Matthew Miller from comment #5)
> We got a note that this affects F21 too. Since that's 10.0 instead of 5.5,
> do you want a new bug for that?

Not necessary, but build on the way already, thanks for pointing to that, I thought 10.0.15 is already in F21, which turned to be wrong expectation.

Comment 8 Fedora Update System 2014-12-19 05:06:20 UTC
mariadb-10.0.15-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/mariadb-10.0.15-2.fc21

Comment 9 Fedora Update System 2014-12-20 08:36:33 UTC
mariadb-5.5.40-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-01-07 01:24:10 UTC
mariadb-10.0.15-3.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.