Bug 117373 - Secure (ie useful) DAV does not appear to work
Secure (ie useful) DAV does not appear to work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-03 07:49 EST by Alan Cox
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-15 11:28:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2004-03-03 07:49:37 EST
In computer select 'create server' (at least I assume thats the Englsh
for it)
Host: whatever
Address: https://137.44.10.1

it now waits forever and fails to make a DAV connection. While in this
state if you delete the icon nautilus crashes.

Doing the same with an http:// DAV connection seems to work although
I've not verified the redirect bugs in nautilus 2.4 have gone away
Comment 1 Alexander Larsson 2004-03-03 08:02:22 EST
Do you mean "File -> Connect to server", under "Open Location..."?

I've seen the crash for this mentioned before (for ftp servers), but i
can't reproduce it here.
Comment 2 Alan Cox 2004-03-03 08:14:29 EST
Yes. It crashes some of the time and not others. I guess something is
referencing the deleted object and its down to luck.
Comment 3 Alexander Larsson 2004-03-04 06:47:42 EST
Shit. It seems like HAVE_OPENSSL isn't defined when building with
openssl! That explains this a bit...

Btw, any chance for a backtrace when it crashes?
Comment 4 Alexander Larsson 2004-03-04 06:57:50 EST
Ok, fixed the ssl thing upstream.
Comment 5 Alexander Larsson 2004-03-04 10:09:11 EST
Just for you i fixed the redirect issue too.
Comment 6 Alan Cox 2004-03-04 11:35:20 EST
Dude you rock. I forgive you for spacial mode.

I'll give this a good testing once packages appear in the rawhide tree.
Comment 7 Alan Cox 2004-03-05 19:39:55 EST
Still don't work in rawhide but I got a handle on the open failure
thing I think.

Any failing setup hangs forever at the "You can stop this.." dialog,
even when the underlying connection 404's or resets. A simple example
is to create a link to a server with the URL
"http://127.0.0.1/nosuchdocument" and open it.

Comment 8 Alan Cox 2004-03-11 18:07:47 EST
Ok the basics seem to be working now. I'm getting stuff spewed at me
(pasted below), The invalid URL hang on open and never report the
error bug is still present.

** (process:23318): WARNING **: Credentials byte was not nul
PROPFIND:2: parser warning : xmlns:D: 'DAV:' is not a valid URI
<D:multistatus xmlns:D="DAV:">
                             ^
PROPFIND:2: parser warning : xmlns:D: 'DAV:' is not a valid URI
<D:multistatus xmlns:D="DAV:">
                             ^
PROPFIND:2: parser warning : xmlns:D: 'DAV:' is not a valid URI
<D:multistatus xmlns:D="DAV:">
                             ^
PROPFIND:2: parser warning : xmlns:D: 'DAV:' is not a valid URI
<D:multistatus xmlns:D="DAV:">
                             ^
 
(nautilus:23346): Bonobo-CRITICAL **: file bonobo-control-frame.c:
line 720 (bonobo_control_frame_set_ui_container): assertion
`frame->priv->activated == FALSE' failed
PROPFIND:2: parser warning : xmlns:D: 'DAV:' is not a valid URI
<D:multistatus xmlns:D="DAV:">
                             ^
Comment 9 Alexander Larsson 2004-03-12 03:52:19 EST
The warning is some inherent conflict in the xml/webdav specs. See:
http://mail.gnome.org/archives/gnome-vfs-list/2004-February/msg00008.html

The hang on open is fixed in nautilus HEAD.
Comment 10 Alexander Larsson 2004-03-15 11:28:52 EST
Hang on error open is fixed in 2.5.91-1.

Note You need to log in before you can comment on or make changes to this bug.