Bug 1173766 - [RFE] log collector should collect engine-config settings and domain information
Summary: [RFE] log collector should collect engine-config settings and domain information
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-log-collector
Version: 3.4.4
Hardware: x86_64
OS: All
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Scott Herold
QA Contact: Gonza
URL:
Whiteboard:
Depends On:
Blocks: 1234855
TreeView+ depends on / blocked
 
Reported: 2014-12-12 21:43 UTC by Jake Hunsaker
Modified: 2016-03-09 19:59 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 19:59:40 UTC
oVirt Team: Integration
Target Upstream Version:
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0392 normal SHIPPED_LIVE rhevm-log-collector bug fix and enhancement update 2016-03-10 00:19:00 UTC
oVirt gerrit 36116 master MERGED Collect engine-config and domain information Never

Description Jake Hunsaker 2014-12-12 21:43:41 UTC
Description of problem:

Currently sos/log-collector does not capture engine-config values or domain information.

We should capture both of these as the tunables can help in troubleshooting.
Similarly the domain information can help track AD/IPA issues.

These can currently be dug out from the DB dump, however having them in a plaintext file makes checking these much faster and easier, and a DB is not always available.

Version-Release number of selected component (if applicable):
rhevm-log-collector-3.4.5-1.el6ev.noarch

How reproducible:
Always


Actual results:

engine-config and engine-manage-domains output is not collected.

Expected results:

This information should be collected.

Additional info:

http://gerrit.ovirt.org/#/c/36116/

Comment 1 Gonza 2015-07-07 12:19:52 UTC
Verified with:
ovirt-log-collector-3.6.0-0.1.master.20150528070835.git82e9694.el6.noarch
sos-3.2-28.el6.noarch

Comment 4 errata-xmlrpc 2016-03-09 19:59:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0392.html


Note You need to log in before you can comment on or make changes to this bug.