Bug 1173780 - re-enable gold for ppc64/ppc64le and s390x
Summary: re-enable gold for ppc64/ppc64le and s390x
Alias: None
Product: Fedora
Classification: Fedora
Component: binutils
Version: 27
Hardware: ppc64
OS: Linux
Target Milestone: ---
Assignee: Nick Clifton
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2014-12-12 22:59 UTC by Karsten Hopp
Modified: 2018-03-13 23:18 UTC (History)
3 users (show)

Fixed In Version: binutils-2.29.1-2.fc28, binutils-2.29-12.fc27 binutils-2.29-13.fc27
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2018-03-13 23:18:07 UTC
Type: Bug

Attachments (Terms of Use)

Description Karsten Hopp 2014-12-12 22:59:17 UTC
Description of problem:
binutils fails to build on ppc64, make aborts with 'Makefile:830: recipe for target 'all' failed'

Much earlier in the logs is an error during configure, although I'm not sure if that is just the normal trial and error of configure or if thats related:

checking whether make sets $(MAKE)... checking for vsprintf... yes
configure: error: "unsupported target spu-unknown-elf"
checking for waitpid... Makefile:5965: recipe for target 'configure-gold' failed
make[1]: *** [configure-gold] Error 1
make[1]: *** Waiting for unfinished jobs....
checking for setproctitle... no

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. ppc-koji build f22 binutils-2.24-29.fc22.src.rpm

Actual results:

Expected results:

Additional info:
I think all the f22 binutils ppc64 builds failed with the same error, but most of the logs got deleted already.

Comment 1 Karsten Hopp 2015-01-12 13:40:32 UTC
any news here, this is really blocking progress on ppc*  ?

Comment 2 Nick Clifton 2015-01-12 14:25:20 UTC
Hi Karsten,

> any news here, this is really blocking progress on ppc*  ?

Sorry, no news.  Or at least no good news.  The basic problem is that I am totally unable to reproduce this failure locally. :-(

The rawhide binutils sources are now at version binutils-2.25-2.  Perhaps if you try building with this version it will work ?

If not is there any chance that you could narrow down the failure a bit more ?  This message about "spu-unknown-elf" being an unknown target for gold is a bit worrying.  It is true that gold does not support the spu-unknown-elf target, but since you are building for a ppc64 target that message should not have even appeared in the logs.

Alternatively, maybe you could try a patch to the binutils.spec file, like this:
index 8d41f03..a0b4f31 100644
--- a/binutils.spec
+++ b/binutils.spec
@@ -55,7 +55,7 @@ Patch14: binutils-2.24-ldforcele.patch
 Provides: bundled(libiberty)
-%define gold_arches %ix86 x86_64 %arm ppc* %{power64}
+%define gold_arches %ix86 x86_64 %arm 
 %ifarch %gold_arches
 %define build_gold     both
If this works then let me know and I can apply it to the rawhide sources until a proper solution is found.


Comment 3 Karsten Hopp 2015-01-12 16:27:44 UTC
Hi Nick,

binutils-2.25-2 doesn't build, it fails with the same error.

Removing the power arches from gold_arches works around this issue and the build finishes.  


Comment 4 Nick Clifton 2015-01-12 21:01:30 UTC
Hi Karsten,

  OK, I have checked the patch in and created binutils-2.25.3.


Comment 5 Jaroslav Reznik 2015-03-03 16:36:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:

Comment 6 Fedora End Of Life 2016-07-19 20:20:48 UTC
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 7 Dan Horák 2016-11-14 09:07:55 UTC
Reopening, because gold is still disabled and requires special handling in some packages (recently pypy3 5.5). As a result all Fedora "non-experimental architectures" (= all except mips or riscv) will have gold.

scratch build with gold enabled for ppc64/ppc64le (aka %{power64}) is http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=3875757

and it turns out that s390(x) also supports gold now, so a scratch build is at http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2402116

diff --git a/binutils.spec b/binutils.spec
index 04291da..90acf7e 100644
--- a/binutils.spec
+++ b/binutils.spec
@@ -91,9 +91,7 @@ Patch20: binutils-2.27-objdump-improvements.patch
 Provides: bundled(libiberty)
-# BZ 1173780: Building GOLD for PPC is not working at the moment.
-# %define gold_arches %ix86 x86_64 %arm aarch64 ppc* %{power64}
-%define gold_arches %ix86 x86_64 %arm aarch64
+%define gold_arches %ix86 x86_64 %arm aarch64 %{power64} s390x
 %if %{with bootstrap}
 %define build_gold     no

Comment 8 Fedora End Of Life 2017-02-28 09:39:29 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 26 development cycle.
Changing version to '26'.

Comment 9 Nick Clifton 2017-12-18 15:17:02 UTC
As reported this is already fixed in rawhide.  I have now updated F27 so that
gold for powerpc and s390x is enabled there too.  I am not going to update F26
however, (unless there is an outcry), as that uses a relatively older version
of the FSF binutils sources.

Fixed in:  binutils-2.29-12.fc27

Comment 10 Fedora Update System 2018-03-08 14:21:22 UTC
binutils-2.29-13.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1e994c659e

Comment 11 Fedora Update System 2018-03-08 16:24:46 UTC
binutils-2.29-13.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1e994c659e

Comment 12 Fedora Update System 2018-03-13 23:18:07 UTC
binutils-2.29-13.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.