Bug 1173825 - sddm-kcm writes obsolete sddm.conf syntax that sddm does not understand anymore
Summary: sddm-kcm writes obsolete sddm.conf syntax that sddm does not understand anymore
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sddm-kcm
Version: 21
Hardware: i386
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1173834 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-13 10:29 UTC by Toby Newman
Modified: 2015-01-30 04:37 UTC (History)
11 users (show)

Fixed In Version: sddm-kcm-0-0.5.20140114gitfe615f21.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-27 03:09:22 UTC


Attachments (Terms of Use)
Changes configuration locations to newer format and adds 'Session' value to configuration options for automatic login. (5.29 KB, patch)
2015-01-04 21:47 UTC, Vincent Damewood
no flags Details | Diff

Description Toby Newman 2014-12-13 10:29:15 UTC
Description of problem:
SDDM auto login not working.

Version-Release number of selected component (if applicable):
KDE Development Platform 4.14.3

How reproducible:
100%

Steps to Reproduce:
1. Fresh install of Fedora 21 KDE spin.
2. In KDE System Settings, in "Login Screen (SDDM)" settings, tick "Auto Login" and choose an existing user from the combo box.
3. Reboot the machine.

Actual results:
Selected user does not auto login.

Expected results:
Selected user should auto login.

Additional info:

/etc/sddm.conf is as follows:

[General]
AutoRelogin=true
AutoUser=claire
CursorTheme=
HaltCommand=
MaximumUid=65000
MinimumUid=1000
RebootCommand=

Comment 1 Kevin Kofler 2014-12-13 20:52:08 UTC
*** Bug 1173834 has been marked as a duplicate of this bug. ***

Comment 2 Kevin Kofler 2014-12-13 21:01:01 UTC
SDDM is working fine, it's sddm-kcm which is broken. It is still writing the old SDDM 0.9 sddm.conf entries, but the settings have been reorganized in SDDM 0.10. The KCM needs to be updated.

Comment 3 HotMusicFan 2015-01-02 14:31:36 UTC
Example of working confoguration in /etc/sddm.conf is:

[Autologin]
Session=kde-plasma.desktop
User=<user name>

[General]
AutoRelogin=false
AutoUser=
CursorTheme=Default
HaltCommand=
MaximumUid=65000
MinimumUid=1000
RebootCommand=

I found this from another user in Fedora forums.

Comment 4 Vincent Damewood 2015-01-04 21:47:31 UTC
Created attachment 976106 [details]
Changes configuration locations to newer format and adds 'Session' value to configuration options for automatic login.

I've changed the groups and names of any configuration directives that were previously alterable in sddm.conf.

Upstream repositories apparently moved to: https://projects.kde.org/projects/kde/workspace/sddm-kcm/repository

When I tried to manually edit the configuration file, I got a solid black screen when the Session was set incorrectly. So I've added the ability to set it. I've included two additional files from the projects.kde.org repository mentioned above to support changing this value. These files were apparently written for Qt 5 (and perhaps KDE 5), So I altered them to work with Fedora 21 as it is.

Comment 5 Martin Bříza 2015-01-21 12:17:13 UTC
Hi Vincent,
sorry for replying this late to this important thread. Thank you for the patch! I just take a look at it and it seems okay from the glance. Could you please tell me what version of sddm-kcm does it target? I didn't find any upstream commit nor Fedora package sources to which would your patch apply.
If this patch is just artificial and I need to apply it manually, just tell me and I'll do so.
Cheers,
Martin

Comment 6 Martin Bříza 2015-01-21 12:49:18 UTC
Sorry, my bad, the patch is fine. Testing now.

Comment 7 Fedora Update System 2015-01-21 14:13:32 UTC
sddm-kcm-0-0.5.20140114gitfe615f21.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/sddm-kcm-0-0.5.20140114gitfe615f21.fc21

Comment 8 Fedora Update System 2015-01-21 14:14:13 UTC
sddm-kcm-0-0.5.20140114gitfe615f21.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sddm-kcm-0-0.5.20140114gitfe615f21.fc20

Comment 9 Fedora Update System 2015-01-21 23:07:35 UTC
Package sddm-kcm-0-0.5.20140114gitfe615f21.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sddm-kcm-0-0.5.20140114gitfe615f21.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1027/sddm-kcm-0-0.5.20140114gitfe615f21.fc20
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-01-27 03:09:22 UTC
sddm-kcm-0-0.5.20140114gitfe615f21.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-01-30 04:37:09 UTC
sddm-kcm-0-0.5.20140114gitfe615f21.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.