Bug 117387 - ccm upgrade does not maintain ordering of Java & SQL scripts
Summary: ccm upgrade does not maintain ordering of Java & SQL scripts
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Web Application Framework
Classification: Retired
Component: installation   
(Show other bugs)
Version: nightly
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Justin Ross
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 113496
TreeView+ depends on / blocked
 
Reported: 2004-03-03 15:25 UTC by Daniel Berrange
Modified: 2007-04-18 17:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-06 14:43:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Berrange 2004-03-03 15:25:48 UTC
Description of problem:
The Java portion of the upgrade process will typically require that
the SQL schema upgrade has already been done. There may, however, be
cases where there needs to be mulitple java/sql upgrade passes
interleaved. THe ccm upgrade command currently mindlessly runs

   1. All Java scripts
   2. All SQL scripts.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Write an upgrade containing multiple SQL & Java scripts

Actual results:
All Java scripts are run before all SQLK scripts

Expected results:
All scripts are run in the order defined in the .upgrade XML file.


Additional info:

Comment 1 Justin Ross 2004-03-03 18:37:29 UTC
Oh right, this is quite broken (it's the cause of the core and cms
6.0-6.1 upgrade problems).  Making this a blocker.

Comment 2 Justin Ross 2004-03-04 17:52:05 UTC
Fixed at perforce change 41041.


Note You need to log in before you can comment on or make changes to this bug.