Bug 1173902 - compilation of custom kernel ends with depmod error: module needs unknown symbol
Summary: compilation of custom kernel ends with depmod error: module needs unknown symbol
Keywords:
Status: CLOSED DUPLICATE of bug 126342
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 21
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-13 21:16 UTC by Alessandro Selli
Modified: 2014-12-14 19:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-14 19:35:03 UTC


Attachments (Terms of Use)
Compilation log for kernel 3.17.4-302 (11.50 KB, text/plain)
2014-12-13 21:16 UTC, Alessandro Selli
no flags Details

Description Alessandro Selli 2014-12-13 21:16:01 UTC
Created attachment 968208 [details]
Compilation log for kernel 3.17.4-302

Description of problem:
Updated Fedora20 to 21 with yum (https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum?rd=YumUpgradeFaq).
Followed instructions on http://fedoraproject.org/wiki/Building_a_custom_kernel to build a custom kernel using a config file (make oldconfig) for a custom 3.17.4-200 kernel previously compiled and running in the Fedora20 system.
Package creation fails after many depmod "[module] needs unknown symbol" warnings.
Package creation went through after talking away these modules from kernel config:
1) File systems  ---> Miscellaneous filesystems  ---> Journalling Flash File System v2 (JFFS2) support
2) Device Drivers  ---> USB support  ---> Wireless USB Host Controller Interface (WHCI) driver
3) Device Drivers  ---> USB support  ---> BCMA usb host driver 
4) Networking support  ---> WiMAX Wireless Broadband support

Version-Release number of selected component (if applicable):
kernel-3.17.4-301.fc21.src.rpm and kernel-3.17.4-302.fc21.src.rpm


How reproducible:
Always


Steps to Reproduce:
1. Follow custom kernel build instructions on http://fedoraproject.org/wiki/Building_a_custom_kernel using config file available at http://alessandro.route-add.net/Unixalia/Kernel/biostar_p4m90-m4_piv_3.17.4-302.txt plus the modules listed under the "Description of problem" heading.
2.
3.

Actual results:
error: Bad exit status from /var/tmp/rpm-tmp.9GZDNQ (%build)
Exit status: 1
Log error with last 80 lines of rpmbuild -bb command attached.


Expected results:
Custom kernel packages should have been made without errors.


Additional info:

Comment 1 Josh Boyer 2014-12-14 19:35:03 UTC
This is probably because of the kernel-core/kernel-drivers and/or kernel-modules-extra split.  It does depmod to make sure each package has it's dependencies met so there aren't modules that wind up broken after installation.

You kind of need to adjust based on that.

*** This bug has been marked as a duplicate of bug 126342 ***


Note You need to log in before you can comment on or make changes to this bug.