Bug 1173989 - Error connecting to server
Summary: Error connecting to server
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Guenther Deschner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-14 16:50 UTC by piio
Modified: 2016-07-19 12:32 UTC (History)
13 users (show)

Fixed In Version:
Clone Of:
Environment:
Last Closed: 2016-07-19 12:32:07 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description piio 2014-12-14 16:50:15 UTC
Description of problem:
After update to newest evolution-mapi (and related samba and openchange packages) evolution is still asking for password, in journal i can see:
Failed to parse dcerpc binding 'ncacn_ip_tcp:exchange.domain.local[seal,]'

Version-Release number of selected component (if applicable):
3.13.8-1.fc22.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Update evolution-mapi to 3.13.8-1.fc22.x86_64, samba-4.2.0.0-0.2.rc2.fc22.x86_64, openchange-2.2-2.fc22.x86_64
2. Open evolution with configured evolution-mapi account
3. Popup for password will be shown, after passing correct password where it will be asking again and again

Actual results:
Now working evolution-mapi account

Expected results:
Working evolution-mapi account

Additional info:

Comment 1 Milan Crha 2014-12-22 12:53:32 UTC
Thanks for a bug report. Maybe the store of the account broke due to version change. Could you try to go to Edit->Preferences->Mail Accounts-><MAPI account>->Edit->Receiving Email tab and click the Authenticate button there, please? It will update information in the underlying profiles file.

The parse error of the dcerpc binding suggests an issue in samba itself.

Comment 2 piio 2014-12-22 18:11:01 UTC
I tried re-authenticate using provided steps, but it didn't work - I still have authentication loop, in journal i see mentioned 'Failed to parse dcerpc binding 'ncacn_ip_tcp:exchange.domain.local[seal,]'' error.

Comment 3 Milan Crha 2015-01-06 08:31:50 UTC
Okay, thanks for trying it. I'm out of idea right now, thus I move this to samba for better investigation what might fail in the parse. If you have new-enough Exchange server (2007+), then I'd recommend to try evolution-ews for now.

Comment 4 piio 2015-01-07 07:17:33 UTC
Hi,

I use evolution-ews for another (Exchange 2010) account, but I can't use this with this account (Exchange 2003).

Thanks for your help.

Comment 5 Andreas Schneider 2015-01-07 10:11:15 UTC
We need a debug log to see what is going on. I don't know how to turn on samba log output with openchange components ...

Comment 6 Milan Crha 2015-01-07 10:30:04 UTC
(In reply to piio from comment #4)
> I use evolution-ews for another (Exchange 2010) account, but I can't use
> this with this account (Exchange 2003).

Aah, I see, it makes sense.

(In reply to Andreas Schneider from comment #5)
> We need a debug log to see what is going on.

Piio, please run evolution as this:
   $ LIBMAPI_DEBUG=15 evolution &>log.txt
then re-authenticate again. Please note that the log will be huge and will expose quite much private information, from server addresses to emails and eventually passwords. How large and how much information it'll expose depends on how far the connection process will go.

Andreas, the value of LIBMAPI_DEBUG is passed directly to SetMAPIDebugLevel() (as a number). If there is any better value, then please suggest it.

Comment 7 piio 2015-01-07 10:40:01 UTC
Hi,

I tried to debug using LIBMAPI_DEBUG=15 and I have in logfile:


(evolution:20658): GLib-GObject-WARNING **: The property GtkSettings:gtk-button-images is deprecated and shouldn't be used anymore. It will be removed in a future version.

** (evolution-alarm-notify:20667): WARNING **: AT-SPI: Could not obtain desktop path or name


** (evolution:20658): WARNING **: AT-SPI: Could not obtain desktop path or name


** (evolution:20658): WARNING **: atk-bridge: GetRegisteredEvents returned message with unknown signature

** (evolution:20658): WARNING **: atk-bridge: get_device_events_reply: unknown signature

** (evolution:20658): WARNING **: atk-bridge: get_device_events_reply: unknown signature

(evolution:20658): GLib-GObject-WARNING **: The property GtkSettings:gtk-menu-images is deprecated and shouldn't be used anymore. It will be removed in a future version.
No bp log location saved, using default.
[000:000] Cpu: 6.58.9, x4, 3300Mhz, 7890MB
[000:001] Computer model: Not available
[000:001] Browser XEmbed support present: 1
[000:001] Browser toolkit is Gtk2.
[000:009] Using Gtk2 toolkit
No bp log location saved, using default.
[000:000] Cpu: 6.58.9, x4, 3300Mhz, 7890MB
[000:000] Computer model: Not available

(evolution:20658): GLib-GObject-WARNING **: The property GtkCellRendererPixbuf:stock-id is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:20658): GLib-GObject-WARNING **: The property GtkSettings:gtk-toolbar-style is deprecated and shouldn't be used anymore. It will be removed in a future version.
openjdk version "1.8.0_40"
OpenJDK Runtime Environment (build 1.8.0_40-b12)
OpenJDK 64-Bit Server VM (build 25.40-b16, mixed mode)

(evolution:20658): GLib-GObject-WARNING **: The property GtkMisc:xpad is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:20658): GLib-GObject-WARNING **: The property GtkColorButton:color is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:20658): GLib-GObject-WARNING **: The property GtkAlignment:left-padding is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:20658): GLib-GObject-WARNING **: The property GtkAlignment:bottom-padding is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:20658): GLib-GObject-WARNING **: The property GtkButton:use-stock is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:20658): GLib-GObject-WARNING **: The property GtkButton:xalign is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:20658): GLib-GObject-WARNING **: The property GtkAlignment:xscale is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:20658): GLib-GObject-WARNING **: The property GtkMisc:yalign is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:20658): GLib-GObject-WARNING **: The property GtkWidget:margin-left is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:20658): GLib-GObject-WARNING **: The property GtkWidget:margin-right is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:20658): GLib-GObject-WARNING **: The property GtkAlignment:top-padding is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:20658): GLib-GObject-WARNING **: The property GtkAlignment:right-padding is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:20658): GLib-GObject-WARNING **: The property GtkAlignment:yscale is deprecated and shouldn't be used anymore. It will be removed in a future version.
INFO: Current debug levels:
  all: 15
  tdb: 15
  printdrivers: 15
  lanman: 15
  smb: 15
  rpc_parse: 15
  rpc_srv: 15
  rpc_cli: 15
  passdb: 15
  sam: 15
  auth: 15
  winbind: 15
  vfs: 15
  idmap: 15
  quota: 15
  acls: 15
  locking: 15
  msdfs: 15
  dmapi: 15
  registry: 15
  scavenger: 15
  dns: 15
  ldb: 15
Failed to parse dcerpc binding 'ncacn_ip_tcp:exchange.domain.com[print,seal,]'
Failed to connect to remote server: ncacn_ip_tcp:exchange.domain.com[print,seal,] NT_STATUS_INVALID_PARAMETER_MIX
Failed to parse dcerpc binding 'ncacn_ip_tcp:exchange.domain.com[print,seal,]'
Failed to connect to remote server: ncacn_ip_tcp:exchange.domain.com[print,seal,] NT_STATUS_INVALID_PARAMETER_MIX
INFO: Current debug levels:
  all: 15
  tdb: 15
  printdrivers: 15
  lanman: 15
  smb: 15
  rpc_parse: 15
  rpc_srv: 15
  rpc_cli: 15
  passdb: 15
  sam: 15
  auth: 15
  winbind: 15
  vfs: 15
  idmap: 15
  quota: 15
  acls: 15
  locking: 15
  msdfs: 15
  dmapi: 15
  registry: 15
  scavenger: 15
  dns: 15
  ldb: 15
Failed to parse dcerpc binding 'ncacn_ip_tcp:exchange.domain.com[print,seal,]'
Failed to connect to remote server: ncacn_ip_tcp:exchange.domain.com[print,seal,] NT_STATUS_INVALID_PARAMETER_MIX
Failed to parse dcerpc binding 'ncacn_ip_tcp:exchange.domain.com[print,seal,]'
Failed to connect to remote server: ncacn_ip_tcp:exchange.domain.com[print,seal,] NT_STATUS_INVALID_PARAMETER_MIX
INFO: Current debug levels:
  all: 15
  tdb: 15
  printdrivers: 15
  lanman: 15
  smb: 15
  rpc_parse: 15
  rpc_srv: 15
  rpc_cli: 15
  passdb: 15
  sam: 15
  auth: 15
  winbind: 15
  vfs: 15
  idmap: 15
  quota: 15
  acls: 15
  locking: 15
  msdfs: 15
  dmapi: 15
  registry: 15
  scavenger: 15
  dns: 15
  ldb: 15
Failed to parse dcerpc binding 'ncacn_ip_tcp:exchange.domain.com[print,seal,]'
Failed to connect to remote server: ncacn_ip_tcp:exchange.domain.com[print,seal,] NT_STATUS_INVALID_PARAMETER_MIX
Failed to parse dcerpc binding 'ncacn_ip_tcp:exchange.domain.com[print,seal,]'
Failed to connect to remote server: ncacn_ip_tcp:exchange.domain.com[print,seal,] NT_STATUS_INVALID_PARAMETER_MIX
INFO: Current debug levels:
  all: 15
  tdb: 15
  printdrivers: 15
  lanman: 15
  smb: 15
  rpc_parse: 15
  rpc_srv: 15
  rpc_cli: 15
  passdb: 15
  sam: 15
  auth: 15
  winbind: 15
  vfs: 15
  idmap: 15
  quota: 15
  acls: 15
  locking: 15
  msdfs: 15
  dmapi: 15
  registry: 15
  scavenger: 15
  dns: 15
  ldb: 15
Failed to parse dcerpc binding 'ncacn_ip_tcp:exchange.domain.com[print,seal,]'
Failed to connect to remote server: ncacn_ip_tcp:exchange.domain.com[print,seal,] NT_STATUS_INVALID_PARAMETER_MIX
Failed to parse dcerpc binding 'ncacn_ip_tcp:exchange.domain.com[print,seal,]'
Failed to connect to remote server: ncacn_ip_tcp:exchange.domain.com[print,seal,] NT_STATUS_INVALID_PARAMETER_MIX
INFO: Current debug levels:
  all: 15
  tdb: 15
  printdrivers: 15
  lanman: 15
  smb: 15
  rpc_parse: 15
  rpc_srv: 15
  rpc_cli: 15
  passdb: 15
  sam: 15
  auth: 15
  winbind: 15
  vfs: 15
  idmap: 15
  quota: 15
  acls: 15
  locking: 15
  msdfs: 15
  dmapi: 15
  registry: 15
  scavenger: 15
  dns: 15
  ldb: 15
Failed to parse dcerpc binding 'ncacn_ip_tcp:exchange.domain.com[print,seal,]'
Failed to connect to remote server: ncacn_ip_tcp:exchange.domain.com[print,seal,] NT_STATUS_INVALID_PARAMETER_MIX
Failed to parse dcerpc binding 'ncacn_ip_tcp:exchange.domain.com[print,seal,]'
Failed to connect to remote server: ncacn_ip_tcp:exchange.domain.com[print,seal,] NT_STATUS_INVALID_PARAMETER_MIX

** (evolution:20658): WARNING **: Shell not finalized on exit

Comment 8 piio 2015-01-10 11:46:22 UTC
After some digging I realized that problem don't happen when I uncheck this account connection settings 'use secure connection' - evolution connects to Exchange 2003 account.

Comment 9 Sumit Bose 2015-01-12 08:09:30 UTC
If your hostname is longer than 15 characters you might be effected by a change how long hostnames are handled, see e.g. https://bugzilla.redhat.com/show_bug.cgi?id=1175710#c9

Comment 10 Andreas Schneider 2015-01-16 09:30:05 UTC
Sumit, there is no netbios involved here.

It looks like the issue is the seal option. Someone needs to step trough dcerpc_parse_binding() and find out at which line it returns NT_STATUS_INVALID_PARAMETER_MIX.

piio can you do that?

Comment 11 piio 2015-01-16 09:50:29 UTC
How I can do this?

Comment 12 Jaroslav Reznik 2015-03-03 16:36:58 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 13 M. 2015-09-23 14:10:50 UTC
Hi,
I'm experiencing exactly this same bug as piio in Fedora 22 trying to connect an exchange account to evolution.
(Failed to parse dcerpc binding 'ncacn_ip_tcp:exchange.domain.com[print,seal,]'
Failed to connect to remote server: ncacn_ip_tcp:exchange.domain.com[print,seal,])

evolution-mapi version: x86_64 3.16.4-1.fc22
openchange version: x86_64-2.2-6.fc22

Could someone please help out on this?
I'd be glad to help if instructed ...

Comment 14 Alexander Bokovoy 2015-09-23 15:46:41 UTC
This looks like a bug in evolution-mapi which uses wrong DCE RPC binding options.

We have a bug in Samba to actually document the syntax (https://bugzilla.samba.org/show_bug.cgi?id=11428) but with Samba 4.2 the low level DCE RPC binding code started to validate syntax closer to what Microsoft has in their specifications.

Comment 15 Milan Crha 2015-09-24 07:08:47 UTC
(In reply to M. from comment #13)
> (Failed to parse dcerpc binding
> 'ncacn_ip_tcp:exchange.domain.com[print,seal,]'
> Failed to connect to remote server:
> ncacn_ip_tcp:exchange.domain.com[print,seal,])

I think it works if you do _not_ turn on debugging of the connection. Nonetheless, if you've new-enough Exchange server (2007+), I suggest to use evolution-ews instead. It operates better in various ways.

(In reply to Alexander Bokovoy from comment #14)
> This looks like a bug in evolution-mapi which uses wrong DCE RPC binding
> options.

As far as I know, evolution-mapi only gives instructions to the openchange (thorugh the mapi profile), which operates on the low level [1]. The bug link you gave is not useful for me. Could you correct the above cited string to the value it might be, which passes the samba connection string checker, please? Maybe, is it the extra comma after the 'seal', which makes the trouble?

[1] https://github.com/openchange/openchange/blob/master/libmapi/IMSProvider.c#L88

Comment 16 M. 2015-09-24 09:19:24 UTC
(In reply to Milan Crha from comment #15)

> I think it works if you do _not_ turn on debugging of the connection.

I only turned on debugging after experiencing problems connecting through the wizard, (as piio stated: "Popup for password will be shown, after passing correct password where it will be asking again and again")

> Nonetheless, if you've new-enough Exchange server (2007+), I suggest to use
> evolution-ews instead. It operates better in various ways.

I'm afraid using evolution-ews is not an option for me (pre-2007 server).

Comment 17 Alexander Bokovoy 2015-09-24 09:27:08 UTC
(In reply to Milan Crha from comment #15)
> (In reply to Alexander Bokovoy from comment #14)
> > This looks like a bug in evolution-mapi which uses wrong DCE RPC binding
> > options.
> 
> As far as I know, evolution-mapi only gives instructions to the openchange
> (thorugh the mapi profile), which operates on the low level [1]. The bug
> link you gave is not useful for me. Could you correct the above cited string
> to the value it might be, which passes the samba connection string checker,
> please? Maybe, is it the extra comma after the 'seal', which makes the
> trouble?
I don't have time right now to dig the source code up and Metze (who rewrote the binding code) is currently at SDC 11 hours away so it has to wait.

Comment 18 Aeon Flux 2016-03-15 17:02:42 UTC
Still not working? 
Not for me on Fedora 23 with samba-2:4.3.6-0.fc23.x86_64, openchange-2.3-8.fc23.x86_64, evolution-mapi-3.18.4-1.fc23.x86_64

Comment 19 Fedora End Of Life 2016-07-19 12:32:07 UTC
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.