This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 117406 - X hangs upon startup in the vm86old system call with 855GM video card
X hangs upon startup in the vm86old system call with 855GM video card
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-03 12:52 EST by Daniel Berrange
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-06 13:51:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
XFree86 config file (2.35 KB, text/plain)
2004-03-03 12:53 EST, Daniel Berrange
no flags Details
XFree startup logs (49.73 KB, text/plain)
2004-03-03 12:54 EST, Daniel Berrange
no flags Details
System messages log (141.57 KB, text/plain)
2004-03-03 12:55 EST, Daniel Berrange
no flags Details

  None (edit)
Description Daniel Berrange 2004-03-03 12:52:08 EST
Description of problem:
When running XFree on a Dell D505 laptop with the 855GM chipset, the X
server process hangs upon startup shortly after activating the
graphics card. Running 'strace' on the 'X' process reveals it waiting
in the vm86old system call. If I kill the process with a signal
(pretty much any severe signal seems to do the trick eg SEGV), it
breaks out of this system call & carries on with startup & appears to
operate normally. Looking at the XFree86 logs shows 


(EE) I810(0): vm86() syscall generated signal 11.
(II) I810(0): EAX=0x00003000, EBX=0x000032e2, ECX=0x0000dc00,
EDX=0x000003c9
(II) I810(0): ESP=0x00000fac, EBP=0x00000fdc, ESI=0x00000000,
EDI=0x00000000
(II) I810(0): CS=0xc000, SS=0x0100, DS=0x0000, ES=0x0000, FS=0x0000,
GS=0x0000
(II) I810(0): EIP=0x00004ad5, EFLAGS=0x00023246
(II) I810(0): code at 0x000c4ad5:
 5a 58 c3 66 51 eb 22 66 51 b5 80 eb 1c 66 51 b5
 81 eb 16 66 51 b5 82 eb 10 66 51 b5 00 eb 0a 66
(II) stack at 0x00001fac:
 46 fc 01 30 2d 30 01 00 c9 51 54 0d 00 00 00 00
 00 20 f2 1f 01 00 01 03 03 00 7b 20 a4 42 09 20
 46 1f ff 1e 00 00 03 50 10 00 00 00 08 00 00 0f
 40 00 00 00 00 00 00 20 00 00 00 00 00 00 00 00
 00 00 01 00 00 00 01 03 00 00 64 5f 00 00 00 06
 00 00 00 32

before it carries on with the rest of XFree startup normally.

This seems to be the same problem reported here:

  http://www.mail-archive.com/devel@xfree86.org/msg05518.html

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run 'redhat-config-xfree86' on a newly installed Dell D505 with
RHEL 3 AS.
2.
3.
  
Actual results:
Hangs shortly after activating the graphics card.

Expected results:


Additional info:

I will attach the XFree logs, and system message logs.
Comment 1 Daniel Berrange 2004-03-03 12:53:53 EST
Created attachment 98249 [details]
XFree86 config file
Comment 2 Daniel Berrange 2004-03-03 12:54:10 EST
Created attachment 98250 [details]
XFree startup logs
Comment 3 Daniel Berrange 2004-03-03 12:55:12 EST
Created attachment 98251 [details]
System messages log
Comment 4 Daniel Berrange 2004-03-03 13:17:16 EST
This email thread provides more detail on the problem & its solution.

http://www.mail-archive.com/devel@xfree86.org/msg05483.html

Comment 7 Mike A. Harris 2005-03-06 13:51:35 EST
Problem should be resolved in Red Hat Enterprise Linux 4.

Note You need to log in before you can comment on or make changes to this bug.