Bug 1174136 - wrongly computed text width with nonascii characters
wrongly computed text width with nonascii characters
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-15 03:54 EST by Karel Volný
Modified: 2015-02-20 03:32 EST (History)
6 users (show)

See Also:
Fixed In Version: hawkey-0.5.3-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-20 03:32:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2014-12-15 03:54:44 EST
Description of problem:
The output is not aligned correctly when the line contains non-ascii characters.

Version-Release number of selected component (if applicable):
dnf-0.6.3-2.fc21.noarch

How reproducible:
always

Steps to Reproduce:
1. LANG="cs_CZ.UTF-8" dnf upgrade
(supposing you have updates available)

Actual results:
...
  Aktualizace    : libreport-cli-2.3.0-5.fc21.x86_64                                                                                                                                                                                  81/202 
  Aktualizace    : samba-client-2:4.1.13-1.fc21.x86_64                                                                                                                                                                                82/202 
  Instalování  : kernel-3.17.6-300.fc21.x86_64                                                                                                                                                                                      83/202 
  Instalování  : kernel-modules-extra-3.17.6-300.fc21.x86_64                                                                                                                                                                        84/202 
  Aktualizace    : qt-mysql-1:4.8.6-18.fc21.x86_64                                                                                                                                                                                    85/202 
  Aktualizace    : gdal-libs-1.11.1-4.fc21.x86_64                                                                                                                                                                                     86/202 
  Aktualizace    : mesa-libGLES-10.3.5-1.20141207.fc21.x86_64                                                                                                                                                                         87/202 
  Aktualizace    : vlgothic-fonts-20141206-1.fc21.noarch                                                                                                                                                                              88/202 
  Aktualizace    : redhat-rpm-config-27-1.fc21.noarch                                                                                                                                                                                 89/202 
  Aktualizace    : qa-tools-workstation-3.7-12.x86_64                                                                                                                                                                                 90/202 
  Aktualizace    : mesa-libxatracker-10.3.5-1.20141207.fc21.x86_64                                                                                                                                                                    91/202 
  Aktualizace    : kernel-headers-3.17.6-300.fc21.x86_64                                                                                                                                                                              92/202 
  Aktualizace    : hicolor-icon-theme-0.14-1.fc21.noarch                                                                                                                                                                              93/202 
  Aktualizace    : flac-libs-1.3.1-1.fc21.x86_64                                                                                                                                                                                      94/202 
  Aktualizace    : fedora-cert-0.5.10.5-1.fc21.noarch                                                                                                                                                                                 95/202 
  Aktualizace    : mesa-libglapi-10.3.5-1.20141207.fc21.i686                                                                                                                                                                          96/202 
  Aktualizace    : mesa-libgbm-10.3.5-1.20141207.fc21.i686                                                                                                                                                                            97/202 
  Aktualizace    : mesa-libEGL-10.3.5-1.20141207.fc21.i686                                                                                                                                                                            98/202 
  Aktualizace    : mesa-libGL-10.3.5-1.20141207.fc21.i686                                                                                                                                                                             99/202 
  Aktualizace    : mesa-dri-drivers-10.3.5-1.20141207.fc21.i686                                                                                                                                                                      100/202 
  Aktualizace    : sqlite-3.8.7.2-1.fc21.i686                                                                                                                                                                                        101/202 
  Aktualizace    : flac-libs-1.3.1-1.fc21.i686                                                                                                                                                                                       102/202 
  Vymazání     : samba-client-2:4.1.12-5.fc21.x86_64                                                                                                                                                                               103/202 
  Vymazání     : qt-devel-1:4.8.6-13.fc21.x86_64                                                                                                                                                                                   104/202 
...

Expected results:
(the colons, package names and x/y columns are aligned vertically)

Additional info:
Comment 1 Honza Silhan 2015-01-05 10:36:15 EST
Thanks for the report, the fix is in PR [1].

[1] https://github.com/rpm-software-management/dnf/pull/189
Comment 2 Fedora Update System 2015-02-15 19:03:40 EST
dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21
Comment 3 Fedora Update System 2015-02-17 03:04:31 EST
Package hawkey-0.5.3-2.fc21, dnf-plugins-core-0.1.5-1.fc21, dnf-0.6.4-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.5.3-2.fc21 dnf-plugins-core-0.1.5-1.fc21 dnf-0.6.4-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2139/dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21
then log in and leave karma (feedback).
Comment 4 Karel Volný 2015-02-17 09:48:07 EST
works for me, thanks!
Comment 5 Fedora Update System 2015-02-20 03:32:55 EST
hawkey-0.5.3-2.fc21, dnf-plugins-core-0.1.5-1.fc21, dnf-0.6.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.