Bug 11742 - Upgrade runs out of disk space during install
Upgrade runs out of disk space during install
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2000-05-30 05:32 EDT by simon.king
Modified: 2007-04-18 12:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-05-30 05:32:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description simon.king 2000-05-30 05:32:26 EDT
I recently attempted to upgrade my RedHat 6.0 to 6.2, and it froze halfway
through package installation. I tried to re-run the upgrade, but this time
it failed while trying to see which packages to install. From looking at
the error messages on the other VCs, I think what happened was that
original upgrade ran out of disk space, corrupting the RPM database, and
then the second time around, there was not enough disk space to rebuild the

I can't remember exactly how my disk was partitioned, but I had large
partitions for /usr, /usr/local, and /home, but only about 100Mb for /tmp
and 100Mb for /. After rebooting in single user mode, df reported that the
/ partition was 100% full - I imagine it was actually /var filled up with
the package data, but I'm not completely sure.

I tried to move /var into /usr/local/var and create a symlink but stupidly
I didn't check that the files had copied across correctly before deleting
the originals, and I ended up with all the files in /usr/local/var owned by
root, which prevented a few daemons from running properly, so in the end I
backed up my /usr, /etc and /home directories to my windows disk and
installed RH6.2 from scratch. I now use one big partition for / instead of
trying to predict how I will use the disk in the future.

This looks like the same bug as Bug 236, but that was marked as fixed in
RH6.0. If you need any more information I will try and provide it.
Comment 1 Brock Organ 2000-06-10 01:29:28 EDT
hmmm... following up on your disk filling up hunch (since df reported / was full
in single mode) I tried to upgrade 6.0 -> 6.2 on an almost full system:

Disk /dev/hda: 255 heads, 63 sectors, 1650 cylinders                            
Units = cylinders of 16065 * 512 bytes                                           
% fdisk -l /dev/hda
Device Boot    Start       End    Blocks   Id  System                           
/dev/hda1   *         1       153   1228941   83  Linux                         
/dev/hda2           154      1650  12024652+   5  Extended                      
/dev/hda5           154       170    136521   82  Linux swap                     

% df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda1             1.1G  1.1G  9.4M  99% /  

After installing a full 6.0 install, I tried upgrading to 6.2 with the
constrained space (ie only 9.4 Mb free, when more would be needed...)

At the beginning of package installation portion of the upgrade, I got an error
dialog: "You don't appear to have enough disk space..." and the upgrade failed
gracefully ... so I was unable to reproduce the problem that way ...

do you have the partition tables as they were before upgrade (ie fdisk -l
/dev/hda, etc.)?  also, what packages did you install in 6.0 that you were going
to upgrade to 6.2 with ...?  also, do you have a "df -h" of the system before
the upgrade?  Perhaps we can reproduce the problem with those pieces of info ...

Thanks for your report!
Comment 2 simon.king 2000-06-12 04:48:49 EDT
I'm afraid I don't have any of this information any more. The main difference
between my previous setup and the one you describe, though, is that I had plenty
of space for the actual install (ie. loads of space in /usr), but not enough in
/tmp or /var or wherever RPM keeps files while it works.

I don't know whether it is related, but when I installed Helix Gnome on my old
6.0 system, the Helix Install program tried to download all the RPMs to /var/tmp
(or somewhere similar), which caused the install to fail when I ran out of
space. Is this just the installer (which I know is nothing to do with you) or is
it RPM that does that?

Sorry I can't be more help - the only thing that I can suggest is that then
installer checks there is space for the new packages, but not whether it has
enough scratch space.

Anyway, thanks for looking into it.

Note You need to log in before you can comment on or make changes to this bug.