Bug 1174253 - [SAP] tuned-profiles-sap sets incorrect vm.max_map_count
Summary: [SAP] tuned-profiles-sap sets incorrect vm.max_map_count
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tuned
Version: 6.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 6.7
Assignee: Jaroslav Škarvada
QA Contact: Tereza Cerna
URL:
Whiteboard:
Depends On:
Blocks: 1228562
TreeView+ depends on / blocked
 
Reported: 2014-12-15 13:54 UTC by Frank Danapfel
Modified: 2019-04-18 20:22 UTC (History)
9 users (show)

Fixed In Version: tuned-0.2.19-15.el6
Doc Type: Bug Fix
Doc Text:
Previously, the value of the vm.max_map_count sysctl settings was set too low (1,000,000) in the sap-netweaver tuned profile, which could affect performance. With this update, vm.max_map_count is set to 2,000,000, which is a value recommended by SAP documentation.
Clone Of:
: 1228562 (view as bug list)
Environment:
Last Closed: 2015-07-22 07:15:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1376 normal SHIPPED_LIVE tuned bug fix update 2015-07-20 17:58:39 UTC

Description Frank Danapfel 2014-12-15 13:54:33 UTC
Description of problem:
SAP requires that vm.max-map_count is set to 2000000 (see http://service.sap.com/sap/support/notes/1496410 and http://service.sap.com/sap/support/notes/900929), the sap-netweaver tuned profile however only sets it to 1000000

Version-Release number of selected component (if applicable):
tuned-profiles-sap-0.2.19-13.el6_6.1

How reproducible:
always

Steps to Reproduce:
1. check value in profile or run sysctl vm.max_map_count after profile has been activated
2.
3.

Actual results:
[root]# grep vm.max_map_count /etc/tune-profiles/sap-netweaver/*
/etc/tune-profiles/sap-netweaver/sysctl.ktune:vm.max_map_count = 1000000

Expected results:
[root@ls3229v4 ~]# grep vm.max_map_count /etc/tune-profiles/sap-netweaver/*
/etc/tune-profiles/sap-netweaver/sysctl.ktune:vm.max_map_count = 2000000

Additional info:

Comment 4 Tereza Cerna 2015-03-18 09:19:00 UTC
===============================================
Verified in version:
    tuned-0.2.19-15.el6.noarch
    tuned-profiles-sap-0.2.19-15.el6.noarch
PASSED
===============================================

# tuned-adm profile sap-netweaver
Reverting to saved sysctl settings: [  OK  ]
Calling '/etc/ktune.d/tunedadm.sh stop': [  OK  ]
Reverting to cfq elevator: dm-0 dm-1 sda [  OK  ]
Stopping tuned: [  OK  ]
Switching to profile 'sap-netweaver'
Applying deadline elevator: dm-0 dm-1 sda [  OK  ]
Applying sysctl settings from /etc/sysctl.conf
Applying ktune sysctl settings:
/etc/ktune.d/tunedadm.conf: [  OK  ]
Calling '/etc/ktune.d/tunedadm.sh start': [  OK  ]
Starting tuned: [  OK  ]

# sysctl vm.max_map_count
vm.max_map_count = 2000000

# grep vm.max_map_count /etc/tune-profiles/sap-netweaver/*
/etc/tune-profiles/sap-netweaver/sysctl.ktune:vm.max_map_count = 2000000

===============================================
Verified in version:
    tuned-0.2.19-13.el6_6.1.noarch
    tuned-profiles-sap-0.2.19-13.el6_6.1.noarch
PASSED
===============================================

# tuned-adm profile sap-netweaver
Switching to profile 'sap-netweaver'
Applying deadline elevator: dm-0 dm-1 dm-2 vda [  OK  ]
Applying sysctl settings from /etc/sysctl.conf
Applying ktune sysctl settings:
/etc/ktune.d/tunedadm.conf: [  OK  ]
Calling '/etc/ktune.d/tunedadm.sh start': [  OK  ]
Starting tuned: [  OK  ]

# sysctl vm.max_map_count
vm.max_map_count = 1000000

# grep vm.max_map_count /etc/tune-profiles/sap-netweaver/*
/etc/tune-profiles/sap-netweaver/sysctl.ktune:vm.max_map_count = 1000000

Comment 5 Tereza Cerna 2015-03-18 09:57:56 UTC
Sorry for typing error.

PASSED in new versions of packages:
    tuned-0.2.19-15.el6.noarch
    tuned-profiles-sap-0.2.19-15.el6.noarch

FAILED in old version of packages:
    tuned-0.2.19-13.el6_6.1.noarch
    tuned-profiles-sap-0.2.19-13.el6_6.1.noarch

Comment 6 errata-xmlrpc 2015-07-22 07:15:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1376.html


Note You need to log in before you can comment on or make changes to this bug.