Bug 1174293 - When starting the undercloud VMs they fail with "no bootable device"
Summary: When starting the undercloud VMs they fail with "no bootable device"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack
Version: 6.0 (Juno)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ga
: Director
Assignee: James Slagle
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-15 15:10 UTC by Udi
Modified: 2015-08-05 13:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:49:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Udi 2014-12-15 15:10:37 UTC
Description of problem:
When the VMs go from "shut off" state to "running", they first try to boot from PXE. At this stage, after they're already provisioned, they should only be booting from their hard disk. The boot fails and you have no other option but to open a console to see the problem. Then you can see the failed PXE boot and the message "no bootable device". You have to send ctrl+alt+del to the VM to boot it again and it boots from the HD.


Version-Release number of selected component (if applicable):
instack-undercloud-1.0.25-1.fc22.noarch


How reproducible:
100%


Steps to Reproduce:
1. Complete an installation with instack-virt-setup and instack-install-undercloud
2. Open virt-manager on your laptop and establish a remote connection to the host of your VMs. You should see the instack and the 4 "baremetal" machines (2 of them will be shut off but the others are running)
3. Shut off all the running VMs and try to boot them up again. Keep a console open to see the boot messages


Actual results:
No bootable device

Comment 1 James Slagle 2014-12-15 15:14:23 UTC
(In reply to Udi from comment #0)
> Description of problem:
> When the VMs go from "shut off" state to "running", they first try to boot
> from PXE. At this stage, after they're already provisioned, they should only
> be booting from their hard disk. 

This is not a correct statement. The vm's are PXE booted on every boot. This is how Ironic works.

The undercloud must be running to serve PXE/tftp/dhcp services to the overcloud nodes (whether vm or baremetal).

Comment 3 James Slagle 2014-12-17 12:59:55 UTC
please see my earlier comment. was the undercloud running?

Comment 4 Udi 2014-12-17 13:30:34 UTC
The instack VM (undercloud) was not yet running because the host rebooted and all the VMs were started manually, not necessarily in the right order. 

Perhaps it's possible, in this case, that the controller will fall back to booting from its other bootable devices (meaning boot from the hard disk) if the PXE boot fails.

Comment 5 James Slagle 2014-12-17 13:34:25 UTC
it's not possible now, perhaps as a future feature it will be.

Comment 9 chris alfonso 2015-06-15 19:10:22 UTC
We've added a local boot feature, so you should be able to no longer reproduce the issue.

Comment 11 Udi 2015-06-29 10:55:19 UTC
Verified in puddle 2015-06-26

Comment 13 errata-xmlrpc 2015-08-05 13:49:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.