Bug 1174324 - [abrt] zint-qt: __stack_chk_fail_local(): zint-qt killed by SIGABRT
Summary: [abrt] zint-qt: __stack_chk_fail_local(): zint-qt killed by SIGABRT
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: zint
Version: 20
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Gieseking
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:327260721b034dd149c6c2b0cf1...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-15 16:06 UTC by Wilhelm.Buchmueller
Modified: 2014-12-29 10:03 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-29 09:57:38 UTC


Attachments (Terms of Use)
File: backtrace (52.31 KB, text/plain)
2014-12-15 16:06 UTC, Wilhelm.Buchmueller
no flags Details
File: cgroup (168 bytes, text/plain)
2014-12-15 16:06 UTC, Wilhelm.Buchmueller
no flags Details
File: core_backtrace (321 bytes, text/plain)
2014-12-15 16:06 UTC, Wilhelm.Buchmueller
no flags Details
File: dso_list (26.01 KB, text/plain)
2014-12-15 16:06 UTC, Wilhelm.Buchmueller
no flags Details
File: environ (3.20 KB, text/plain)
2014-12-15 16:06 UTC, Wilhelm.Buchmueller
no flags Details
File: limits (1.29 KB, text/plain)
2014-12-15 16:06 UTC, Wilhelm.Buchmueller
no flags Details
File: maps (80.58 KB, text/plain)
2014-12-15 16:06 UTC, Wilhelm.Buchmueller
no flags Details
File: open_fds (524 bytes, text/plain)
2014-12-15 16:06 UTC, Wilhelm.Buchmueller
no flags Details
File: proc_pid_status (799 bytes, text/plain)
2014-12-15 16:06 UTC, Wilhelm.Buchmueller
no flags Details
File: var_log_messages (253 bytes, text/plain)
2014-12-15 16:06 UTC, Wilhelm.Buchmueller
no flags Details

Description Wilhelm.Buchmueller 2014-12-15 16:06:22 UTC
Description of problem:
Scrolling through all barcode types with a number results in crash.

Version-Release number of selected component:
zint-qt-2.4.3-6.fc20

Additional info:
reporter:       libreport-2.2.3
backtrace_rating: 4
cmdline:        zint-qt
crash_function: __stack_chk_fail_local
executable:     /usr/bin/zint-qt
kernel:         3.17.6-200.fc20.i686+PAE
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #6 __stack_chk_fail_local at /lib/libzint.so.2.4
 #7 kix_code at /usr/src/debug/zint-2.4.3/backend/postal.c:419
 #8 reduced_charset at /usr/src/debug/zint-2.4.3/backend/library.c:537
 #9 ZBarcode_Encode at /usr/src/debug/zint-2.4.3/backend/library.c:661
 #10 Zint::QZint::encode at /usr/src/debug/zint-2.4.3/backend_qt4/qzint.cpp:81
 #11 Zint::QZint::render at /usr/src/debug/zint-2.4.3/backend_qt4/qzint.cpp:316
 #12 BarcodeItem::paint at /usr/src/debug/zint-2.4.3/frontend_qt4/barcodeitem.cpp:39
 #13 QGraphicsScenePrivate::draw at graphicsview/qgraphicsscene.cpp:4964
 #14 QGraphicsScenePrivate::drawSubtreeRecursive at graphicsview/qgraphicsscene.cpp:4857
 #15 QGraphicsScenePrivate::drawItems at graphicsview/qgraphicsscene.cpp:4739

Comment 1 Wilhelm.Buchmueller 2014-12-15 16:06:27 UTC
Created attachment 969129 [details]
File: backtrace

Comment 2 Wilhelm.Buchmueller 2014-12-15 16:06:28 UTC
Created attachment 969130 [details]
File: cgroup

Comment 3 Wilhelm.Buchmueller 2014-12-15 16:06:29 UTC
Created attachment 969131 [details]
File: core_backtrace

Comment 4 Wilhelm.Buchmueller 2014-12-15 16:06:31 UTC
Created attachment 969132 [details]
File: dso_list

Comment 5 Wilhelm.Buchmueller 2014-12-15 16:06:32 UTC
Created attachment 969133 [details]
File: environ

Comment 6 Wilhelm.Buchmueller 2014-12-15 16:06:34 UTC
Created attachment 969134 [details]
File: limits

Comment 7 Wilhelm.Buchmueller 2014-12-15 16:06:37 UTC
Created attachment 969135 [details]
File: maps

Comment 8 Wilhelm.Buchmueller 2014-12-15 16:06:39 UTC
Created attachment 969136 [details]
File: open_fds

Comment 9 Wilhelm.Buchmueller 2014-12-15 16:06:40 UTC
Created attachment 969137 [details]
File: proc_pid_status

Comment 10 Wilhelm.Buchmueller 2014-12-15 16:06:41 UTC
Created attachment 969138 [details]
File: var_log_messages

Comment 11 Wilhelm.Buchmueller 2014-12-15 16:17:05 UTC
The problem is in the "Dutch Post KIX" after the 12th character.

Comment 12 Martin Gieseking 2014-12-18 12:53:32 UTC
I've tracked down the origin of this bug and will push the updated packages shortly.

Comment 13 Fedora Update System 2014-12-18 13:01:12 UTC
zint-2.4.3-9.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/zint-2.4.3-9.fc21

Comment 14 Fedora Update System 2014-12-18 13:01:18 UTC
zint-2.4.3-9.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/zint-2.4.3-9.fc20

Comment 15 Fedora Update System 2014-12-18 13:01:25 UTC
zint-2.4.3-9.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/zint-2.4.3-9.fc19

Comment 16 Fedora Update System 2014-12-19 18:27:38 UTC
Package zint-2.4.3-9.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing zint-2.4.3-9.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-17242/zint-2.4.3-9.fc21
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2014-12-29 09:57:38 UTC
zint-2.4.3-9.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2014-12-29 10:03:11 UTC
zint-2.4.3-9.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2014-12-29 10:03:35 UTC
zint-2.4.3-9.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.