Bug 117461 - (ALSA NM256)no sound on SONY PCG-F360
(ALSA NM256)no sound on SONY PCG-F360
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: SELinux
Depends On:
Blocks: FC2Target FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-03-04 04:04 EST by Steve Ward
Modified: 2015-01-04 17:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:24:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of lspci -vv (5.62 KB, text/plain)
2004-03-04 04:08 EST, Steve Ward
no flags Details
output of dmesg from normal boot (10.08 KB, text/plain)
2004-03-12 22:54 EST, Steve Ward
no flags Details

  None (edit)
Description Steve Ward 2004-03-04 04:04:07 EST
Description of problem:
No sound udible on system since loading FC2-test1.  Drivers all load
correctly, soundcard is detected, mixer controls appear to work, but
no sound.

Version-Release number of selected component (if applicable):

kernel-2.6.3-1.118

How reproducible:

Always.  Got loop of partial sound one time only.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Steve Ward 2004-03-04 04:08:19 EST
Created attachment 98276 [details]
output of lspci -vv
Comment 2 Steve Ward 2004-03-05 23:26:28 EST
Upgraded to kernel-2.6.3-2.1.238.i686.rpm...now system locks hard when
soundcard driver attempts to load under X (running the
soundcard-detection utility, as soon as you press "play test sound" it
locks up solid, must power off).  Tried disabling ACPI and tried
pci=usepirqmask as recommended in boot messages.  No change.
Comment 3 Steve Ward 2004-03-09 20:21:42 EST
Upgraded to kernel-2.6.3-2.1.242 ... system no longer locks hard, but
still no sound.
Comment 4 Arjan van de Ven 2004-03-10 12:10:45 EST
be aware that ALSA defaults to a sound volume of zero; could you try
running alsa-mixer to increase sound ?
Comment 5 Steve Ward 2004-03-10 12:17:19 EST
Yes, increasing sound I get either nothing or looping sound from the
test tones played by the soundcard detection routine.
Comment 6 Steve Ward 2004-03-12 22:54:41 EST
Created attachment 98508 [details]
output of dmesg from normal boot

Maybe this will help, it looks like maybe interrupts are not getting configured
properly.  Bad BIOS?
Comment 7 Steve Ward 2004-04-06 00:05:36 EDT
Problem still exists on test-2.  Volume Control applet reports "No
mixer device found" but I can run alsamixer from the commandline...it
shows _two_ mixer devices???
Comment 8 Dan Blomberg 2004-04-07 09:45:10 EDT
Fedora Core 2 Test 2 same problem on Compaq Armada E500, Device
information is ES1978 Maestro 2E, driver snd-es1960. output from
running alsamixer at command line  -> "alsamixer: function
snd_ctl_open failed for default: No such device".  when attempting to
icrease the volume control on the panel the volume bar automatically
returns to the bottom.
Comment 9 Steve Ward 2004-04-10 18:25:04 EDT
kernel-2.6.5-1.315 I can get the test sound if I setenforce 0 and I
run the soundcard detection from the command line as root...

The volume control applet still forces everything back to zero volume
and I can't seem to get any sound out of the CD drive either...
Comment 10 Dave Jones 2004-12-08 00:43:22 EST
did this get fixed with the latest updates ?
Comment 11 Steve Ward 2004-12-08 00:55:01 EST
This machine is now running FC3.  Last time I tested sound worked if OSS 
compatible devices were used.  Native ALSA didn't work. 
Comment 12 Dave Jones 2005-04-16 01:24:27 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.