Bug 1174612 - RFE: backport --assumeno option to yum
Summary: RFE: backport --assumeno option to yum
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum
Version: 6.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Valentina Mukhamedzhanova
QA Contact: Karel Srot
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-16 05:54 UTC by Paul Wayper
Modified: 2019-02-15 13:56 UTC (History)
6 users (show)

Fixed In Version: yum-3.2.29-65.el6
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 07:21:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1384 normal SHIPPED_LIVE yum bug fix and enhancement update 2015-07-20 18:07:41 UTC
Red Hat Knowledge Base (Solution) 1320213 None None None Never

Description Paul Wayper 2014-12-16 05:54:27 UTC
Description of problem:

Yum has the ability to determine the download size and the installed size of an install, upgrade or remove operation.  However, this is only made available in the information provided at the interactive prompt.  For automated upgrades, it would be useful to supply this information either in human-readable format or in some kind of machine-readable format (e.g. JSON or YAML).  This can then be read into standard configuration management utilities - e.g. Puppet - to make sure that an update only occurs when it is has enough space.

It would also be useful to break this down into space required per file system.

Version-Release number of selected component (if applicable):

yum-3.2.29-43.el6_5.noarch

How reproducible:

Always

Steps to Reproduce:
1. Find a package you don't have installed on your system.
2. yum install ${missing_package} | grep size

Actual results:

Total download size: 9.8 M
Installed size: 42 M

Expected results:

download_size=9812345
installed_size=42123456

Additional info:

Comment 2 Valentina Mukhamedzhanova 2014-12-17 09:56:13 UTC
Since yum already supplies this information in human-readable format and the output can be grepped, I believe if we backport --asumeno that would be sufficient for this request?

--assumeno
Assume no; assume that the answer to any question which would  be  asked  is  no.  This option overrides assumeyes, but is still subject to alwaysprompt. Configuration Option: assumeno

Comment 3 Paul Wayper 2014-12-22 03:22:10 UTC
Hi Valentina,

How much detail does yum actually get?  Can it give an output per mount point?

For the customer that originally raised this issue, this would be more useful - but the aggregate download and installed space requirements would be acceptable.

The main thought of having a separate output is just to save using grep and/or having it mis-trigger - e.g. 'yum install perl-Image-Size | grep -i size' is going to get confused with false positive lines.  It also saves a bunch of output that isn't necessary for the final result.

Backporting --assumeno plus writing a KCS article to detail how to use this option plus grep to get size calculations would be a reasonable compromise.

Thanks,

Paul

Comment 4 Valentina Mukhamedzhanova 2015-01-20 14:39:48 UTC
Hi Paul,

No, it doesn't have a per mount point information, it only has size for each package.

Thank you for the details, I'll look into backporting --assumeno.

Comment 17 Paul Wayper 2015-03-08 23:58:23 UTC
I accept that back-porting the --assumeno flag is the best practical solution.

Thanks,

Paul

Comment 19 errata-xmlrpc 2015-07-22 07:21:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1384.html


Note You need to log in before you can comment on or make changes to this bug.