Bug 117463 - man prints debug lines on exit
Summary: man prints debug lines on exit
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Target
TreeView+ depends on / blocked
 
Reported: 2004-03-04 10:19 UTC by Michael Young
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 1.5m2-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-12 21:35:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Young 2004-03-04 10:19:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
With man-1.5m2-3, groff-1.18.1-33 and glibc-common-2.3.3-13 when I use
q to quit from any man page I get lines like

/usr/bin/nroff: line 69:  1648 Done                    /usr/bin/iconv
-f ${charset_in} -t utf-8 ${TMPFILE}
      1649                       | /usr/bin/groff -mtty-char -Tutf8
$opts 2>/dev/null
      1652 Broken pipe             | /usr/bin/iconv -f utf-8 -t
${charset_out}//translit

left on the terminal. Ideally man should quit quietly unless there are
problems.

Comment 1 Michael Young 2004-03-04 10:45:40 UTC
Actually it only seems to be occuring on long man pages (eg. man man)
where you quit on an early page, scrolling to the end and then
quitting exits silently as expected.


Note You need to log in before you can comment on or make changes to this bug.