Bug 1174744 - overwritten HTML page generated by sepolicy manpage -w -d ...
Summary: overwritten HTML page generated by sepolicy manpage -w -d ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: policycoreutils
Version: 7.1
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Petr Lautrbach
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-16 12:13 UTC by Milos Malik
Modified: 2017-08-01 16:16 UTC (History)
9 users (show)

Fixed In Version: policycoreutils-2.5-13.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 16:16:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1883 normal SHIPPED_LIVE policycoreutils bug fix update 2017-08-01 17:53:54 UTC

Description Milos Malik 2014-12-16 12:13:05 UTC
Description of problem:
 * for two different domains the sepolicy tool generates two HTML files of the same name but different content

Version-Release number of selected component (if applicable):
policycoreutils-devel-2.2.5-15.el7.x86_64
policycoreutils-sandbox-2.2.5-15.el7.x86_64
policycoreutils-2.2.5-15.el7.x86_64
policycoreutils-restorecond-2.2.5-15.el7.x86_64
policycoreutils-newrole-2.2.5-15.el7.x86_64
policycoreutils-python-2.2.5-15.el7.x86_64

How reproducible:
always

Steps to Reproduce:
# sepolicy manpage -d sssd_t -w
/tmp/sssd_selinux.8
/tmp/RHEL7/sssd.html
/tmp/index.html has been created
/tmp/RHEL7/RHEL7.html has been created
/tmp/style.css has been created
# ls -l /tmp/RHEL7/sssd.html 
-rw-r--r--. 1 root root 22515 Dec 16 13:09 /tmp/RHEL7/sssd.html
# sepolicy manpage -d sssd_selinux_manager_t -w
/tmp/sssd_selinux_manager_selinux.8
/tmp/RHEL7/sssd.html
/tmp/index.html has been created
/tmp/RHEL7/RHEL7.html has been created
/tmp/style.css has been created
# ls -l /tmp/RHEL7/sssd.html 
-rw-r--r--. 1 root root 13279 Dec 16 13:09 /tmp/RHEL7/sssd.html
# 

The first file is overwritten by the second.

Comment 1 Miroslav Grepl 2015-03-03 20:12:34 UTC
We should back port all sepolicy-manpage changes to 7.2 from Fedora.

Comment 3 Petr Lautrbach 2015-07-21 14:50:48 UTC
I'll provide a build with backported fix from Fedora until end of this week.

Comment 13 errata-xmlrpc 2017-08-01 16:16:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1883


Note You need to log in before you can comment on or make changes to this bug.