Bug 1174763 - Services fail to restart and reload during instack-install-undercloud
Summary: Services fail to restart and reload during instack-install-undercloud
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack
Version: Director
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ga
: Director
Assignee: James Slagle
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-16 12:44 UTC by Udi
Modified: 2015-08-05 13:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:49:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Udi 2014-12-16 12:44:40 UTC
Description of problem:
If you look in the log file .instack/install-undercloud.log you can find these messages logged:

+ service openvswitch-switch restart
Redirecting to /bin/systemctl restart  openvswitch-switch.service
Failed to issue method call: Unit openvswitch-switch.service failed to load: No such file or directory.

+ service httpd reload
Redirecting to /bin/systemctl reload  httpd.service
Job for httpd.service failed. See 'systemctl status httpd.service' and 'journalctl -xn' for details.



Version-Release number of selected component (if applicable):
nstack-undercloud-1.0.25-1.fc22.noarch


How reproducible:
100%


Steps to Reproduce:
1. Install on bare metal according to https://openstack.redhat.com/Deploying_an_RDO_Undercloud_with_Instack


Additional Info:
It is not known if any use cases are affected by the errors, however it is an indication of a possible problem.

Comment 5 Udi 2015-06-07 06:40:22 UTC
Doesn't happen with the latest puddle 2015-06-02

Comment 6 chris alfonso 2015-06-15 19:11:32 UTC
Udi, please ensure the latest puddle fixed and move the bug to resolved appropriately.

Comment 9 errata-xmlrpc 2015-08-05 13:49:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.