Bug 1174798 - pcs stonith describe only lists parameters of fence agent, but not description
Summary: pcs stonith describe only lists parameters of fence agent, but not description
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcs
Version: 6.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 6.7
Assignee: Tomas Jelinek
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-16 14:04 UTC by Frank Danapfel
Modified: 2015-07-22 06:15 UTC (History)
4 users (show)

Fixed In Version: pcs-0.9.138-1.el6
Doc Type: Bug Fix
Doc Text:
* After displaying information about a fence agent, pcs showed the description of the options but not the description of the fence agent itself. Now, the fence agent description is displayed as well in this situation. (BZ#1174798)
Clone Of:
: 1206219 (view as bug list)
Environment:
Last Closed: 2015-07-22 06:15:56 UTC


Attachments (Terms of Use)
proposed fix (9.78 KB, patch)
2015-01-07 15:45 UTC, Tomas Jelinek
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1446 normal SHIPPED_LIVE pcs bug fix and enhancement update 2015-07-20 18:43:57 UTC

Description Frank Danapfel 2014-12-16 14:04:14 UTC
Description of problem:
The output of "pcs stonith describwe <name of fence agent>" does not contain a description about the fence agent which can make it difficult to figure out if an agent is the correct one.


Version-Release number of selected component (if applicable):
pcs-0.9.123-9.el6

How reproducible:
always

Steps to Reproduce:
1. pcs stonith describe <name of fence agent>
2.
3.

Actual results:
[root]# pcs stonith describe fence_ipmilan
Stonith options for: fence_ipmilan
  auth: IPMI Lan Auth type (md5, password, or none)
  ipaddr: IPMI Lan IP to talk to
...


Expected results:
[root]# pcs stonith describe fence_ipmilan
fence_ipmilan is an I/O Fencing agent which can be used with machines controlled by IPMI. This agent calls support software using ipmitool (http://ipmitool.sf.net/).
To use fence_ipmilan with HP iLO 3 or HP iLO 4 you have to enable lanplus option (lanplus / -P) and increase wait after operation to 4 seconds (power_wait=4 / -T 4)

Stonith options for: fence_ipmilan
  auth: IPMI Lan Auth type (md5, password, or none)
  ipaddr: IPMI Lan IP to talk to
...

Additional info:
The description above was obtained by running "strings /usr/sbin/fence_ipmilan" and looking for something that vaguely looks kie a description.

Comment 2 Tomas Jelinek 2015-01-07 15:45:31 UTC
Created attachment 977410 [details]
proposed fix

Test:

[root@rh66-node1:~]# pcs stonith describe fence_ipmilan
fence_ipmilan - Fence agent for IPMI over LAN

 fence_ipmilan is an I/O Fencing agent which can be used with machines
 controlled by IPMI. This agent calls support software using ipmitool
 (http://ipmitool.sf.net/). To use fence_ipmilan with HP iLO 3 or HP iLO 4 you
 have to enable lanplus option (lanplus / -P) and increase wait after operation
 to 4 seconds (power_wait=4 / -T 4)

Stonith options:
  auth: IPMI Lan Auth type (md5, password, or none)
  ipaddr: IPMI Lan IP to talk to
...

Comment 3 Tomas Jelinek 2015-01-27 13:30:05 UTC
Before Fix:
[root@rh66-node1 ~]# rpm -q pcs
pcs-0.9.123-9.el6.x86_64

[root@rh66-node1:~]# pcs stonith describe fence_ipmilan
Stonith options for: fence_ipmilan
  auth: IPMI Lan Auth type (md5, password, or none)
  ipaddr: IPMI Lan IP to talk to
...



After Fix:
[root@rh66-node1:~]# rpm -q pcs
pcs-0.9.138-1.el6.x86_64

[root@rh66-node1:~]# pcs stonith describe fence_ipmilan
fence_ipmilan - Fence agent for IPMI over LAN

fence_ipmilan is an I/O Fencing agent which can be used with machines controlled by IPMI. This agent calls support software using ipmitool (http://ipmitool.sf.net/).

To use fence_ipmilan with HP iLO 3 or HP iLO 4 you have to enable lanplus option (lanplus / -P) and increase wait after operation to 4 seconds (power_wait=4 / -T 4)

Stonith options:
  auth: IPMI Lan Auth type (md5, password, or none)
  ipaddr: IPMI Lan IP to talk to
...

Comment 7 errata-xmlrpc 2015-07-22 06:15:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1446.html


Note You need to log in before you can comment on or make changes to this bug.