Bug 117480 - If IPSEC (racoon.conf) is used then it will give a kernel panic
If IPSEC (racoon.conf) is used then it will give a kernel panic
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-04 09:05 EST by David Joo
Modified: 2013-08-05 21:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-14 16:14:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
all necessary information about the system as well as netdump (900.53 KB, application/octet-stream)
2004-03-04 09:07 EST, David Joo
no flags Details

  None (edit)
Description David Joo 2004-03-04 09:05:25 EST
Description of problem:
A client uses racoon.conf for IPSEC and it will give kernel panic when
it is being used.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. racoon.conf has been set as following;

remote anonymous 
{ 
exchange_mode main; 
doi ipsec_doi; 
situation identity_only; 
initial_contact off; 
passive on; 
proposal_check obey; 
generate_policy on; 
proposal { 
encryption_algorithm 3des; 
hash_algorithm sha1; 
authentication_method pre_shared_key; 
dh_group 2; 
} 
} 

Actual results:
Kernel Dumps

Expected results:
IPSEC should work

Additional info:

necessary information has been attached in a zip file.

One of the trace call shows following;
Call Trace:   [<c0280e85>] xfrm_policy_gc_kill [kernel] 0x45 (0xf7fa7f50)
[<c012ee9a>] __run_task_queue [kernel] 0x6a (0xf7fa7f74)
[<c013acfd>] context_thread [kernel] 0x13d (0xf7fa7f8c)

The other one follows;
Call Trace:   [<c028092b>] xfrm_policy_gc_task [kernel] 0xbb (0xc46d5f5c)
[<c013ae2d>] context_thread [kernel] 0x13d (0xc46d5f8c)
[<c013acf0>] context_thread [kernel] 0x0 (0xc46d5fe0)
[<c010958d>] kernel_thread_helper [kernel] 0x5 (0xc46d5ff0)


It seems that it is panicing at the same place.
Comment 1 David Joo 2004-03-04 09:07:10 EST
Created attachment 98292 [details]
all necessary information about the system as well as netdump
Comment 2 Jim Paradis 2006-09-14 16:14:35 EDT
Since this issue is outside the scope of the current support status of RHEL2.1,
I am closing it as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.