Bug 1174850 - libappindicator is FTBFS on F21 and later
Summary: libappindicator is FTBFS on F21 and later
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libappindicator
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eduardo Echeverria
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-16 15:30 UTC by Peter Robinson
Modified: 2015-01-14 23:59 UTC (History)
4 users (show)

Fixed In Version: libappindicator-12.10.0-8.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-14 23:59:11 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Peter Robinson 2014-12-16 15:30:53 UTC
libappindicator is FTBFS on F-21 GA (and likely for a few months at least) 

F-22: http://koji.fedoraproject.org/koji/taskinfo?taskID=8398592

F-21: http://koji.fedoraproject.org/koji/taskinfo?taskID=8398819

Comment 1 Eduardo Echeverria 2014-12-29 06:05:28 UTC
Peter, I've added -Wno-deprecated-declarations in CFLAGS and the build has been successful, what do you think? http://koji.fedoraproject.org/koji/taskinfo?taskID=8495440

Comment 2 Peter Robinson 2014-12-30 05:03:55 UTC
(In reply to Eduardo Echeverria from comment #1)
> Peter, I've added -Wno-deprecated-declarations in CFLAGS and the build has
> been successful, what do you think?

As long as the problem is reported upstream so it's tracked to be fixed in a future release I think that's OK for the short term, because they're due to be deprecated it does need to be fixed upstream though

Comment 3 Fedora Update System 2014-12-31 02:35:59 UTC
libappindicator-12.10.0-7.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/libappindicator-12.10.0-7.fc21

Comment 4 Fedora Update System 2015-01-01 08:57:19 UTC
Package libappindicator-12.10.0-7.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libappindicator-12.10.0-7.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-0022/libappindicator-12.10.0-7.fc21
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2015-01-04 14:57:34 UTC
libappindicator-12.10.0-8.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/libappindicator-12.10.0-8.fc21

Comment 6 Fedora Update System 2015-01-14 23:59:11 UTC
libappindicator-12.10.0-8.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.