Bug 117507 - After making a custom kernel usb keyboard and mouse fail
After making a custom kernel usb keyboard and mouse fail
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-04 15:39 EST by Carl Porter
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-10 00:07:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Porter 2004-03-04 15:39:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
After installing RedHat Enterprise Linux Version 3 Workstation with
kernel build extensions, use the manual's custom kernel build
procedure.  After booting the custom kernel, both the USB keyboard and
USB mouse fail to function.

Version-Release number of selected component (if applicable):
kernel-2.4.21-9.0.1.EL and kernel-2.4.21-9.1.EL

How reproducible:
Always

Steps to Reproduce:
1.Install RedHat Enterprise WS Version 3 with kernel source
2.in root, cd /usr/src/linux-2.4
3.make mrproper
4.cp configs/kernel-2.4.21-i686.config .config
5.make menuconfig
6.save config
7.make dep
8.make clean
9.make bzImage
10.make modules
11.make modules_install
12.make install
13.boot new kernel

Actual Results:  USB keyboard and USB mouse stop working.

Expected Results:  USB keyboard and USB mouse continue to function

Additional info:

The appropiate portion of the lsmod output is as follows:

keybdev                 2976   0  (unused)
mousedev                5524   0  (unused)
input                   5920   0  [keybdev mousedev]
hid                    11864   0  (unused)
ehci-hcd               27880   0  (unused)
usb-uhci               26412   0  (unused)
usbcore                86336   1  [hid ehci-hcd usb-uhci]
Comment 1 Carl Porter 2004-03-07 18:54:01 EST
An alternate procedure circumvents problem:
1.su to root and cd /usr/src/linux-2.4
2.make mrproper
3.cp /boot/config-2.4.21-9.0.1.EL .config
4.make oldconfig
5.make oldconfig
6.make clean
7.make bzImage
8.make modules
9.make modules_install
10.make install
11.boot new kernel
Comment 2 Pete Zaitcev 2004-03-09 23:54:06 EST
This is not an alternative procedure, it's the main procedure.
"make oldconfig" is the only thing which works. You do not need
to run it twice.

If you really need menuconfig, do it, but then run oldconfig
to clean up the pieces scattered by menuconfig. Ditto xconfig.
Comment 3 Pete Zaitcev 2004-03-09 23:58:14 EST
Oh wait, I remember now.

There is actually a page a www.redhat.com, which used to recommend
"make xconfig", which, of course, inundated me with bugs...
I complained to Tammy, and she was all ready to throw that
garbage out, when a well meaning support person claimed that
"make oldconfig" was too unfriendly, blah blah. In the end,
a "compromise" was reached, where the page was changed to
recommend menuconfig. It is a little less broken, so actually
this is the first bug about this since then.

So, I guess, officially, menuconfig is the primary procedure,
at least according to the website.
Comment 4 Pete Zaitcev 2004-03-10 00:05:38 EST
Here's the page:
 http://www.redhat.com/docs/manuals/enterprise/RHEL-3-Manual/sysadmin-guide/s1-custom-kernel-modularized.html

Dunno what to do about it. To fix the menuconfig is beyond human
capabilities. To fix the manual is to admit defeat :-)
I think I'll re-close with WONTFIX rather than NOTABUG,
it's more honest that way.

Note You need to log in before you can comment on or make changes to this bug.