Bug 117513 - programs linked to libkdeui crash with relocation error
programs linked to libkdeui crash with relocation error
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
Reported: 2004-03-04 16:06 EST by James Mitchell Ullman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-03-05 11:19:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description James Mitchell Ullman 2004-03-04 16:06:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
When starting any application linked to libkdeui, I receive this
error:  "relocation error: /usr/lib/libkdeui.so.4: undefined symbol:

I've tried multiple programs and have had the same error repeat.

I ran /sbin/ldconfig just to make sure that all the libs were seen and
did not recieve an error from it, so I'm assuming that ldconfig ran fine.

Applications not linked to libkdeui seem to work fine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Open terminal
2.run any kde application ie: kuickshow, kcalc...

Actual Results:  receive error: "relocation error:
/usr/lib/libkdeui.so.4: undefined symbol: _ZN9QComboBox4hideEv"

Expected Results:  Successful application initialisation.

Additional info:
Comment 1 Ngo Than 2004-03-05 10:34:39 EST
it looks like that the libraries are not correctly installed on your
machine. Please make sure that you have to upgrade the current qt/kde
rpms from rawhide and restart KDE after upgrade process.

I cannot reproduce it here on my local machine.
Comment 2 James Mitchell Ullman 2004-03-05 10:46:33 EST
I uninstalled all of kde this morning and have been trying to get it
back on ever since.  Yum won't work to save my life, I guess I'll just
do this the old fashioned way.
Comment 3 James Mitchell Ullman 2004-03-05 11:04:00 EST
I ftp'ed kdelibs, kdebase and kdegraphics.  All installed without any

However, I am still getting the problem.  Something else is messed up
which is causing libkde not to work.

I don't think this is a closed matter.
Comment 4 James Mitchell Ullman 2004-03-05 11:18:46 EST
I just removed EVERY possible thing(minus rehat-artwork) that could
POSSIBLY have anything to do with any kde-derived application.

I then manually ftp'ed qt, kdelibs, kdebase and installed them.

Now, I am able to run qt/kde linked programs.  Apparently either yum
or apt borked some rpms.  I'm really beginning to dislike both.
Comment 5 Ben Smith 2004-06-03 19:29:05 EDT
I saw this.  kdm found some old qt-3.1 libs somehow.  This is on a
machine that was upgraded from RH9 -> FC1 -> kde-3.2.2

I fixed it by removing/renaming /usr/lib/qt-3.1 and running ldconfig.

Note You need to log in before you can comment on or make changes to this bug.