Bug 117522 - esdplay wants to start a new esd every time.
esdplay wants to start a new esd every time.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: esound (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-04 17:12 EST by Aleksey Nogin
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-09 16:55:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2004-03-04 17:12:18 EST
If I run esdplay, the first time it starts esd and plays the sound
fine, but on subsequent invocations instead of connecting to an
existing esd, it tries starting a new esd, fails (because one is
already running) and does not play anything.

% killall esd
% esdplay /usr/share/system-config-soundcard/sound-sample.wav
% esdplay /usr/share/system-config-soundcard/sound-sample.wav
esd: Esound sound daemon already running or stale UNIX socket
/tmp/.esd/socket
This socket already exists indicating esd is already running.
Exiting...

P.S. esdplay -s localhost works OK.
Comment 1 Aleksey Nogin 2004-03-04 17:13:14 EST
P.P.S. Sorry, forgot: esound-0.2.33-1
Comment 2 Robert Vojta 2004-03-06 14:18:38 EST
I tried to reproduce this and I'm not successfull ...

- updated FC1 to 1.90 via yum
- same package

[robert@echelon robert]$ ps ax | grep esd
 2002 pts/6    S      0:00 grep esd
[robert@echelon robert]$ esdplay online.wav
[robert@echelon robert]$ esdplay online.wav
[robert@echelon robert]$ esdplay online.wav

Works fine in both situations - esd is [not] running before first
esdplay call ...
Comment 3 Aleksey Nogin 2004-03-06 21:34:50 EST
- I am using Raw Hide not 1.90
- I am using ALSA.
Comment 4 Robert Vojta 2004-03-07 02:43:47 EST
s/1\.90/rawhide/g

Sorry, my mistake ... I'm using Raw Hide too, same packages and it
works fine with alsa for me.
Comment 5 Aleksey Nogin 2004-03-09 16:55:57 EST
Not sure what changed, but it WFM now.

Note You need to log in before you can comment on or make changes to this bug.