Bug 117534 - CDRW and DVDRW failing totally
Summary: CDRW and DVDRW failing totally
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-05 00:02 UTC by Paul F. Johnson
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-30 16:30:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul F. Johnson 2004-03-05 00:02:20 UTC
Description of problem:
Under the 2.6.3 kernel, it does not seem possible to record either to
CD or DVD

Version-Release number of selected component (if applicable):
cdrecord 2.01-0.a25.4

How reproducible:
Always

Steps to Reproduce:
1. Fire up any CD/DVD writing software
2. Create a list of files to burn (or an ISO image)
3.
  
Actual results:
An error code 11 from mkisofs occurs. k3b complains that cdrao should
be updated to a newer version which supports packet writing 

Expected results:
The CD/DVD should be written to

Additional info:
grub.conf has the drives line set as (after LABEL)

acpi=on hdc=ide-cd hdd=ide-cd hdf=ide-cd selinux=0

ls -l /dev/cdwrite*
/dev/cdwriter -> /dev/sg1
/dev/cdwriter1-> /dev/sg2

ls -l /dev/cdrom*
/dev/cdrom  -> /dev/hdc
/dev/cdrom1 -> /dev/hdd
/dev/cdrom2 -> /dev/hdf

Under the 2.6.2 kernel (compiled from source and with ide-scsi enabled
for both the compilation and on the grub line [/dev/hdf=ide-scsi etc])
CDs and DVDs would burn fine.

Comment 1 Bill Nottingham 2004-03-05 02:45:53 UTC
Are you point it at /dev/cdrom or /dev/cdwriter? If you're not using
ide-scsi, you shouldn't use /dev/sg*.

Comment 2 Harald Hoyer 2004-03-05 10:50:42 UTC
you also want to use:

$ cdrecord -scanbus dev=ATAPI:

and then specify dev=ATAPI:0,0,0 or whatever...

It is true that dvdrecord does not support the new ATAPI interface...
but that would be component dvdrtools, right?

Comment 3 Paul F. Johnson 2004-03-05 22:56:36 UTC
Even after doing that, k3b is still giving me the following error

/opt/schily/bin/mkisofs: Resource temporarily unavailable. cannot
fwrite 2048*1

(it's the same if I use a self compiled version or the Fedora version)

You're right about the dvd recorded though :-(

Comment 4 Paul F. Johnson 2004-03-05 22:57:58 UTC
gtoaster looks for devices on /dev/sg*, so it is kept in there - it
doesn't matter as I can currently not burn to anything!

I can create an iso image though, so mkisofs can't be that screwy!

Comment 5 Harald Hoyer 2004-07-30 13:36:16 UTC
is this still the case? 

Comment 6 Paul F. Johnson 2004-07-30 15:38:32 UTC
Seems to be working fine now. This can be closed


Note You need to log in before you can comment on or make changes to this bug.