Bug 1175351 - schroot binary should be setuid root
Summary: schroot binary should be setuid root
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: schroot
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zach Carter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-17 14:51 UTC by davidk
Modified: 2015-02-15 03:25 UTC (History)
4 users (show)

Fixed In Version: schroot-1.6.5-8.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-15 03:25:14 UTC
Type: Bug


Attachments (Terms of Use)

Description davidk 2014-12-17 14:51:23 UTC
Description of problem:

A fix made to schroot on the Fedora 20 branch did not make it to Fedora 21. See https://bugzilla.redhat.com/show_bug.cgi?id=1045006

schroot fails to start a new session. The error message is as follows:

E: root1-92601c5b-3d12-4b72-96b8-6953979a0cc3: Failed to lock chroot: /var/lib/schroot/session/root1-92601c5b-3d12-4b72-96b8-6953979a0cc3: Failed to write session file: Permission denied
Version-Release number of selected component (if applicable):

schroot.x86_64                       1.6.5-6.fc21

How reproducible:

Always.

Steps to Reproduce:
1. Try to start an schroot session (schroot -c name)
2.
3.

Actual results:
Error, because the binary cannot write to /var/lib/schroot/session/

Expected results:
A shell within the chroot.

Additional info:

Comment 1 André 2015-01-06 19:44:18 UTC
Same results here.

Fedora 21 - 3.17.7.300

Comment 2 Zach Carter 2015-01-30 23:51:28 UTC
Working on it.   Sorry for the delayed response.

Comment 3 Fedora Update System 2015-01-31 01:10:06 UTC
schroot-1.6.5-8.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/schroot-1.6.5-8.fc21

Comment 4 Fedora Update System 2015-02-01 00:24:59 UTC
Package schroot-1.6.5-8.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing schroot-1.6.5-8.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1489/schroot-1.6.5-8.fc21
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2015-02-15 03:25:14 UTC
schroot-1.6.5-8.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.