Bug 117542 - system-config-network crashes and the redhat network alert icon no longer works
system-config-network crashes and the redhat network alert icon no longer works
Status: CLOSED DUPLICATE of bug 117416
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-04 20:22 EST by Don Hardaway
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Hardaway 2004-03-04 20:22:16 EST
Description of problem:
When i tool my laptop to work the essid was different on the router. I
booted and tried to launch the system-config-network tool to change
the essid.  That is when it crashes plus the system does not boot
correctly when the essid is different and you leave your pcmcia
wireless card in while booting. Here is the error info:

Component: system-config-network
Version: 1.3.15
Summary: TBd9d48f1f NewInterfaceDialog.py:27:?:ImportError:
/usr/lib/libgnomeui-2.so.0: undefined symbol:
gtk_file_chooser_set_folder_mode
Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 138, in main
    import netconfpkg.gui.GUI_functions
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/__init__.py",
line 36, in ?
  File "<string>", line 1, in ?
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/NewInterfaceDialog.py",
line 27, in ?
ImportError: /usr/lib/libgnomeui-2.so.0: undefined symbol:
gtk_file_chooser_set_folder_mode

Local variables in innermost frame:
FALSE: False
signal: <module 'signal' (built-in)>
__builtins__: {'help': Type help() for interactive help, or
help(object) for help about object., 'vars': <built-in function vars>,
'SyntaxError': <class exceptions.SyntaxError at 0xb801f77c>,
'unicode': <type 'unicode'>, 'UnicodeDecodeError': <class
exceptions.UnicodeDecodeError at 0xb801fcbc>, 'isinstance': <built-in
function isinstance>, 'copyright': Copyright (c) 2001, 2002, 2003
Python Software Foundation.
All Rights Reserved.

Copyright (c) 2000 BeOpen.com.
All Rights Reserved.

Copyright (c) 1995-2001 Corporation for National Research Initiatives.
All Rights Reserved.

Copyright (c) 1991-1995 Stichting Mathematisch Centrum, Amsterdam.
All Rights Reserved., 'NameError': <class exceptions.NameError at
0xb801f65c>, 'dict': <type 'dict'>, 'input': <built-in function
input>, 'oct': <built-in function oct>, 'SystemExit': <class
exceptions.SystemExit at 0xb801f32c>, 'StandardError': <class
exceptions.StandardError at 0xb801f2cc>, 'repr': <built-in function
repr>, 'IndexError': <class exceptions.IndexError at 0xb801f8fc>,
'False': False, 'RuntimeWarning': <class exceptions.RuntimeWarning at
0xb801ffbc>, 'list': <type 'list'>, 'iter': <built-in function iter>,
'reload': <built-in function reload>, 'Warning': <class
exceptions.Warning at 0xb801fe3c>, 'round': <built-in function round>,
'dir': <built-in function dir>, 'cmp': <built-in function cmp>,
'reduce': <built-in function reduce>, 'intern': <built-in function
intern>, 'issubclass': <built-in function issubclass>, 'Ellipsis':
Ellipsis, 'hash': <built-in function hash>, 'locals': <built-in
function locals>, 'slice': <type 'slice'>, 'FloatingPointError':
<class exceptions.FloatingPointError at 0xb801faac>, 'sum': <built-in
function sum>, 'OverflowWarning': <class exceptions.OverflowWarning at
0xb801ff8c>, 'getattr': <built-in function getattr>, 'abs': <built-in
function abs>, 'exit': 'Use Ctrl-D (i.e. EOF) to exit.', 'True': True,
'FutureWarning': <class exceptions.FutureWarning at 0xb803402c>,
'None': None, 'EOFError': <class exceptions.EOFError at 0xb801f53c>,
'len': <built-in function len>, 'credits': Thanks to CWI, CNRI,
BeOpen.com, Zope Corporation and a cast of thousands
for supporting Python development.  See www.python.org for more
information., '__name__': '__builtin__', 'ord': <built-in function
ord>, 'super': <type 'super'>, '_': <bound method i18n.gettext of
<rhpl.translate.i18n instance at 0xb8001b0c>>, 'TypeError': <class
exceptions.TypeError at 0xb801f2fc>, 'license': Type license() to see
the full license text, 'KeyboardInterrupt': <class
exceptions.KeyboardInterrupt at 0xb801f38c>, 'UserWarning': <class
exceptions.UserWarning at 0xb801fe6c>, 'filter': <built-in function
filter>, 'range': <built-in function range>, 'staticmethod': <type
'staticmethod'>, 'SystemError': <class exceptions.SystemError at
0xb801fddc>, 'pow': <built-in function pow>, 'RuntimeError': <class
exceptions.RuntimeError at 0xb801f56c>, 'float': <type 'float'>,
'StopIteration': <class exceptions.StopIteration at 0xb801f29c>,
'globals': <built-in function globals>, 'divmod': <built-in function
divmod>, 'enumerate': <type 'enumerate'>, 'apply': <built-in function
apply>, 'LookupError': <class exceptions.LookupError at 0xb801f8cc>,
'open': <type 'file'>, 'quit': 'Use Ctrl-D (i.e. EOF) to exit.',
'basestring': <type 'basestring'>, 'UnicodeError': <class
exceptions.UnicodeError at 0xb801fb6c>, 'zip': <built-in function
zip>, 'hex': <built-in function hex>, 'long': <type 'long'>,
'ReferenceError': <class exceptions.ReferenceError at 0xb801fdac>,
'ImportError': <class exceptions.ImportError at 0xb801f3ec>, 'chr':
<built-in function chr>, '__import__': <built-in function __import__>,
'type': <type 'type'>, '__doc__': "Built-in functions, exceptions, and
other objects.\n\nNoteworthy: None is the `nil' object; Ellipsis
represents `...' in slices.", 'Exception': <class exceptions.Exception
at 0xb801f26c>, 'tuple': <type 'tuple'>, 'UnicodeTranslateError':
<class exceptions.UnicodeTranslateError at 0xb801fd4c>,
'UnicodeEncodeError': <class exceptions.UnicodeEncodeError at
0xb801fbfc>, 'IOError': <class exceptions.IOError at 0xb801f47c>,
'hasattr': <built-in function hasattr>, 'delattr': <built-in function
delattr>, 'setattr': <built-in function setattr>, 'raw_input':
<built-in function raw_input>, 'SyntaxWarning': <class
exceptions.SyntaxWarning at 0xb801ff5c>, 'compile': <built-in function
compile>, 'ArithmeticError': <class exceptions.ArithmeticError at
0xb801f98c>, 'str': <type 'str'>, 'property': <type 'property'>,
'MemoryError': <class exceptions.MemoryError at 0xb801fe0c>, 'int':
<type 'int'>, 'xrange': <type 'xrange'>, 'KeyError': <class
exceptions.KeyError at 0xb801f95c>, 'coerce': <built-in function
coerce>, 'PendingDeprecationWarning': <class
exceptions.PendingDeprecationWarning at 0xb801ff2c>, 'file': <type
'file'>, 'EnvironmentError': <class exceptions.EnvironmentError at
0xb801f41c>, 'unichr': <built-in function unichr>, 'id': <built-in
function id>, 'OSError': <class exceptions.OSError at 0xb801f4dc>,
'DeprecationWarning': <class exceptions.DeprecationWarning at
0xb801fecc>, 'min': <built-in function min>, 'execfile': <built-in
function execfile>, 'complex': <type 'complex'>, 'bool': <type
'bool'>, 'ValueError': <class exceptions.ValueError at 0xb801fb0c>,
'NotImplemented': NotImplemented, 'map': <built-in function map>,
'buffer': <type 'buffer'>, 'max': <built-in function max>, 'object':
<type 'object'>, 'TabError': <class exceptions.TabError at
0xb801f83c>, 'callable': <built-in function callable>,
'ZeroDivisionError': <class exceptions.ZeroDivisionError at
0xb801fa1c>, 'eval': <built-in function eval>, '__debug__': True,
'IndentationError': <class exceptions.IndentationError at 0xb801f80c>,
'AssertionError': <class exceptions.AssertionError at 0xb801f89c>,
'classmethod': <type 'classmethod'>, 'UnboundLocalError': <class
exceptions.UnboundLocalError at 0xb801f6bc>, 'NotImplementedError':
<class exceptions.NotImplementedError at 0xb801f5cc>,
'AttributeError': <class exceptions.AttributeError at 0xb801f74c>,
'OverflowError': <class exceptions.OverflowError at 0xb801f9bc>}
TRUE: True
__file__:
/usr/share/system-config-network/netconfpkg/gui/NewInterfaceDialog.pyc
gtk: <module 'gtk' from
'/usr/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.pyc'>
__name__: netconfpkg.gui.NewInterfaceDialog
os: <module 'os' from '/usr/lib/python2.3/os.pyc'>
__doc__: None


Version-Release number of selected component (if applicable):
system-config-network-1.3.15-1.1

How reproducible:
everytime

Steps to Reproduce:
1.launch system-config-network
2.
3.
  
Actual results:
it crashes

Expected results:
launches normally

Additional info:

I had to manually change the essid in the sysconfig network file
before i could use my laptop.  Also, my Redhat network alert icon will
no longer appear on the bottom panel even when selected from the menu
an enlarged green one appears and never turns blue. Now my machine
hangs at the end of the boot process until i click the center screen
boot label.
Comment 1 Bill Nottingham 2004-03-04 21:51:34 EST

*** This bug has been marked as a duplicate of 117416 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.