Bug 1175434 - Odd placement and no rotation of hawkey.log
Odd placement and no rotation of hawkey.log
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hawkey (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: Reopened
: hawkey.log 1185642 (view as bug list)
Depends On: 1149350
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-17 13:03 EST by Subhendu Ghosh
Modified: 2016-10-04 00:31 EDT (History)
10 users (show)

See Also:
Fixed In Version: hawkey-0.5.3-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1149350
Environment:
Last Closed: 2015-01-09 14:08:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Subhendu Ghosh 2014-12-17 13:03:07 EST
+++ This bug was initially created as a clone of Bug #1149350 +++

Bug 1148627 brought my attention to the file /var/cache/dnf/…/hawkey.log.  I have two questions:
1. Is there any particular reason this log isn't placed in /var/log like all other logs.  It would be much easier to find there.
2. Is this log not meant to be rotated/cleaned in any way?  On my system it is currently well over 100MB, and seems to reach back almost a year.  What about adding a /etc/logrotate.d/hawkey to rotate this at some convenient interval?

--- Additional comment from Jan Silhan on 2014-10-06 13:11:13 EDT ---

Hi Goran, good point, but this log is a bit tricky. "hawkey.log" is in sack's cache dir for each sack so the data are not merged from multiple sources. The depsolving output from libsolv should not be mixed by other proceses (PackageKit) to get valid debug info. The other usecase is when dnf developers ask users to compress and upload metadata cache dir we'll also get this log so we can see if sack was properly loaded.

--- Additional comment from Jan Silhan on 2014-10-08 16:09:16 EDT ---

Log file added to dnf logrotate script

--- Additional comment from Fedora Update System on 2014-12-09 09:06:28 EST ---

dnf-0.6.3-2.fc21,dnf-plugins-core-0.1.4-1.fc21,hawkey-0.5.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-0.6.3-2.fc21,dnf-plugins-core-0.1.4-1.fc21,hawkey-0.5.2-1.fc21

--- Additional comment from Fedora Update System on 2014-12-11 23:32:33 EST ---

Package dnf-0.6.3-2.fc21, hawkey-0.5.2-1.fc21, dnf-plugins-core-0.1.4-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.6.3-2.fc21 hawkey-0.5.2-1.fc21 dnf-plugins-core-0.1.4-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-16760/dnf-0.6.3-2.fc21,dnf-plugins-core-0.1.4-1.fc21,hawkey-0.5.2-1.fc21
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2014-12-13 04:53:34 EST ---

dnf-0.6.3-2.fc21, hawkey-0.5.2-1.fc21, dnf-plugins-core-0.1.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 1 Subhendu Ghosh 2014-12-17 13:05:00 EST
Wouldn't it be better if the log was place in /var/log/dnf/<sack>-hawkey.log ?

This way we still have consolidation of log location, and identification of sack specific logs?
Comment 2 Honza Silhan 2015-01-09 14:08:44 EST

*** This bug has been marked as a duplicate of bug 1163438 ***
Comment 3 Fedora Update System 2015-02-15 19:03:33 EST
dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21
Comment 4 Fedora Update System 2015-02-20 03:32:48 EST
hawkey-0.5.3-2.fc21, dnf-plugins-core-0.1.5-1.fc21, dnf-0.6.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Honza Silhan 2015-02-25 13:22:06 EST
*** Bug 1185642 has been marked as a duplicate of this bug. ***
Comment 6 Honza Silhan 2015-04-20 14:51:58 EDT
*** Bug 1178002 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.