Bug 117552 - rhn-applet-gui gives import error
Summary: rhn-applet-gui gives import error
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgnomeui   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-05 09:30 UTC by Michael Young
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-05 10:20:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Young 2004-03-05 09:30:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
With the current FC2T1 development packages I get the error
Traceback (most recent call last):
  File "/usr/bin/rhn-applet-gui", line 30, in ?
    import rhn_applet
  File "/usr/share/rhn/rhn_applet/rhn_applet.py", line 13, in ?
    import gnome.ui
ImportError: /usr/lib/libgnomeui-2.so.0: undefined symbol:
gtk_file_chooser_set_folder_mode
when I try to run rhn-applet-gui. It was working before my last
update, so probably something in the 20040304 changes
http://www.redhat.com/archives/fedora-devel-list/2004-March/msg00194.html
broke it.

Comment 1 Daniel Veillard 2004-03-05 10:20:06 UTC
Apparently know bug, fixed soon
------------------------------------
Date: Fri, 05 Mar 2004 10:04:51 +0000
From: Mark McLoughlin <markmc@redhat.com>
Subject: libgnomeui/gtk+ ABI problems
To: fedora-test-list@redhat.com
                                                                     
          
Hey,
        If you see an error like:
                                                                     
          
/usr/lib/libgnomeui-2.so.0: undefined symbol:
gtk_file_chooser_set_folder_mode
                                                                     
          
        you need to update your libgnomeui to the latest in Raw Hide -
i.e. to
use gtk2-2.3.5-1 you need libgnomeui-2.5.90.1-1.
                                                                     
          
        What happened was libgnomeui was using some recently
introduced gtk+
functions which were removed in gtk+ 2.3.5 so we needed to respin
libgnomeui. I didn't add a Conflicts: since I don't think that's
neccessary for random transient Raw Hide b0rkage.
                                                                     
          
Thanks,
Mark.



Note You need to log in before you can comment on or make changes to this bug.