Bug 117564 - File Selector/Chooser: Choosing directories from list sometimes goes to root directory
File Selector/Chooser: Choosing directories from list sometimes goes to root ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk+ (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-05 08:38 EST by scott white
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-12 17:33:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description scott white 2004-03-05 08:38:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
I'm running Fedora Core 2 test 1 on i686. Choosing my directories from
the list (not from the left list box) sometimes takes the file
selector to my root dir (/), and not to the intended directory. Again,
this is the list below the current path buttons. I have verified that
it happens in gEdit, ggv, and other GNOME apps that use the file
selector. 

Maybe related, rhn-applet-gui fro the command line fails with this error:

File "/usr/bin/rhn-applet-gui", line 30, in ?
import rhn_applet
File "/usr/share/rhn/rhn_applet/rhn_applet.py", line 13, in ?
import gnome.ui
ImportError: /usr/lib/libgnomeui-2.so.0: undefined symbol:
gtk_file_chooser_set_folder_mode



let me know if you need more info,
scott

Version-Release number of selected component (if applicable):
gtk+-1.2.10-29.1 gtk2-2.3.5-1

How reproducible:
Always

Steps to Reproduce:
1. Open gEdit
2. Choose Open from File Menu
3. Navigate to a directory from the main window
    

Actual Results:  After reaching two directories deep ( ie
/home/myhome/), clicking on a third directory causes the file selector
to go to root directory

Expected Results:  I expect the file selector to go to the selected dir

Additional info:
Comment 1 Owen Taylor 2004-03-05 09:11:08 EST
I think this has been fixed in GNOME CVS; there should be new
packages in the tree at the beginning of next week.

Note You need to log in before you can comment on or make changes to this bug.