Bug 117567 - Program doesn't access root before trying to configure networking
Summary: Program doesn't access root before trying to configure networking
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-netstatus   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Target
TreeView+ depends on / blocked
 
Reported: 2004-03-05 14:28 UTC by Mike Chambers
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 2.6.0.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-10 12:07:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Chambers 2004-03-05 14:28:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
Once you click on configure, you get errors stating that you can't
copy /etc/hosts file to the networking dir due to incorrect
permissions.  As someone stated in their email, looks like it's just
not accessing root first.

Version-Release number of selected component (if applicable):
gnome-netstatus-0.16-1

How reproducible:
Always

Steps to Reproduce:
1.Right click on applet
2.Click on properties
3.Click on Configure on bottom of menu
    

Actual Results:  system-config-network:

Error copying 
//etc/hosts
to //etc/sysconfig/networking/profiles//default/hosts:
[Errno 13] Permission denied:
'//etc/sysconfig/networking/profiles//default/hosts'!

Then...

system-config-network:

Error copying 
//etc/resolv.conf
to //etc/sysconfig/networking/profiles//default/resolv.conf:
[Errno 13] Permission denied:
'//etc/sysconfig/networking/profiles//default/resolv.conf'!

Then....

system-config-network:

Please start system-config-network with root permissions once!

Expected Results:  Should ask for root password and get root
permissions after pressing the Configure button.

Additional info:

Comment 1 Mike Chambers 2004-03-19 14:57:09 UTC
Has there been any work on this as of late?

Comment 2 Mark McLoughlin 2004-04-14 15:23:13 UTC
NEEDINFO is something used by developers to say "I need more
information from the reporter". Marking your bug as NEEDINFO is a sure
fire way to make sure it doesn't show up on the developer's radar

Comment 3 Mike Chambers 2004-06-10 12:07:02 UTC
This seems to be fixed with lastest package in rawhide.  Marking as
closed/fixed.


Note You need to log in before you can comment on or make changes to this bug.