Bug 1175680 - cannot wake up VM from hibernation if multiple queues is used
Summary: cannot wake up VM from hibernation if multiple queues is used
Keywords:
Status: CLOSED DUPLICATE of bug 1176148
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: 3.6.0
Assignee: Nobody
QA Contact: Meni Yakove
URL:
Whiteboard: network
Depends On:
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-12-18 11:30 UTC by Martin Pavlik
Modified: 2016-02-10 19:59 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-23 09:48:55 UTC
oVirt Team: Network


Attachments (Terms of Use)
log_collector (14.19 MB, application/x-xz)
2014-12-18 11:30 UTC, Martin Pavlik
no flags Details
fail to run after hibrenate (766.26 KB, application/x-gzip)
2014-12-23 09:19 UTC, Michael Burman
no flags Details

Description Martin Pavlik 2014-12-18 11:30:06 UTC
Created attachment 970492 [details]
log_collector

Description of problem:
when multiple queues feature is applied on the VM network, VM does not wake up from hybernation

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.5.0-0.25.el6ev
vdsm-4.16.8.1-3.el7ev.x86_64
libvirt-daemon-1.1.1-29.el7_0.3.x86_64
libvirt-daemon-driver-qemu-1.1.1-29.el7_0.3.x86_64

How reproducible:
100%

Steps to Reproduce:
1. set support for multiple queues on engine with following command
engine-config -s 'CustomDeviceProperties={type=interface;prop={queues=[1-9][0-9]*}}'

select version 3.5

2. service ovirt-engine restart
3. Networks -> rhevm -> vNIC profiles -> rhevm -> edit
   in VM interfce select queues and input number 5
4. start VM with rhevm network connected (wait until VM is UP)
5. suspend VM
6. start VM

Actual results:
VM VM1 is down with error. Exit message: Wake up from hibernation failed.

Expected results:
VM wakes up from hybernation

Additional info:

2014-12-18 11:58:45,786 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (org.ovirt.thread.pool-7-thread-40) Correlation ID: 442831d6, Job ID: 37f1aa32-b351-4725-a569-38af1cd517c4, Call Stack: null, Custom Event ID: -1, Message: Failed to run VM VM1 (User: admin).

Comment 1 Michal Skrivanek 2014-12-22 11:23:41 UTC
seems the attachment is corrupted. can you please try again. Or just check qemu log for 
qemu: warning: error while loading state for instance 0x0 of device '0000:00:03.0/virtio-net'

to be sure it's the same as bug 1176148

Comment 2 Dan Kenigsberg 2014-12-22 13:38:02 UTC
Much like bug 1176148, it should not block 3.5.0.

Comment 3 Dan Kenigsberg 2014-12-22 13:45:17 UTC
But the effect on bug 821493 is worsened... /me goes to make the release note even tougher.

Comment 4 Michael Burman 2014-12-23 08:49:17 UTC
I will provide the logs soon. Have to say that when tested this feature and created the test cases for the 821493 BZ, hibernation and migration with multiple queues worked as expected.

Comment 5 Michael Burman 2014-12-23 09:19:28 UTC
Created attachment 972333 [details]
fail to run after hibrenate

Comment 6 Michael Burman 2014-12-23 09:20:45 UTC
Attached libvirt, vdsm and qemu logs.
VM name- Mic3

Comment 7 Michal Skrivanek 2014-12-23 09:48:55 UTC
confirmed it's the same issue, crash few seconds after a migration finishes

*** This bug has been marked as a duplicate of bug 1176148 ***


Note You need to log in before you can comment on or make changes to this bug.